Interactive Line Mode -nodms

Accepted Solution Solved
Reply
New Contributor
Posts: 2
Accepted Solution

Interactive Line Mode -nodms

Hi,

I'm running SAS 9.3 on Linux and working remotely and I'd rather not use X (poor connection etc) so I'm using -nodms (and tried -nodmsexp....whats the difference?) for interactive line mode.  This works most of the time, however I've now tried importing a 4million line CSV file, and I'm getting a message back about X being unavailable:

ERROR: The connection to the X display server could not be made <blah>

ERROR: Device does not support full-screen.

At this point things seem to hang.  Trying this with an X connection, and the import completes and returns a prompt however a SAS Session Management window is opened, despite the nodms flag.

I'm not particularly experienced with SAS and am mainly involved as a Linux system admin level.  Is there anyway to get true GUI-less SAS?

Thanks,

Chris


Accepted Solutions
Solution
‎03-02-2014 11:00 AM
Super User
Super User
Posts: 6,500

Re: Interactive Line Mode -nodms

Most likely the message is from PROC IMPORT. For a CSV file there is very little value in using PROC IMPORT.  Just write the data step yourself.  You can copy and paste the variable names from the first line of the CSV file if you do not already know what variables there are.

data want ;

length var1 8 var2 $30 ...... varn 8 ;

infile 'myfile.csv' dsd dlm=',' truncover firstobs=2 lrecl=32000;

input var1--varn ;

run;

You can also create a simple .sas program and run it from the command line non-interactively.  Then you can use the -noterminal option to prevent that type of error message.

> sas -noterminal myprogram.sas

> more myprogram.log

>

View solution in original post


All Replies
Solution
‎03-02-2014 11:00 AM
Super User
Super User
Posts: 6,500

Re: Interactive Line Mode -nodms

Most likely the message is from PROC IMPORT. For a CSV file there is very little value in using PROC IMPORT.  Just write the data step yourself.  You can copy and paste the variable names from the first line of the CSV file if you do not already know what variables there are.

data want ;

length var1 8 var2 $30 ...... varn 8 ;

infile 'myfile.csv' dsd dlm=',' truncover firstobs=2 lrecl=32000;

input var1--varn ;

run;

You can also create a simple .sas program and run it from the command line non-interactively.  Then you can use the -noterminal option to prevent that type of error message.

> sas -noterminal myprogram.sas

> more myprogram.log

>

New Contributor
Posts: 2

Re: Interactive Line Mode -nodms

Thanks! I didn't realise the proc import would generate a message and require a window.  I have been using a .sas script generally, rather than working interactively, but ran into this issue while testing.

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 2 replies
  • 552 views
  • 0 likes
  • 2 in conversation