How can I explain SAS to Tell it - don't show it?

Reply
New Contributor
Posts: 2

How can I explain SAS to Tell it - don't show it?

I have a SAS program producing a lot of output - last run: no less than 924 pdf files each containing a single graph.

It has worked perfectly in SAS 9.2 and 9,3 - however in SAS 9.4 I am overloaded with output on the screen when the program has done its work. When finished SAS OPENS 924 pdf-files!!!!!!! and I have to close each and every of these. Can you imagine 924 open pdf-files? NO- of cause. My Adobe can't imagine this eiher. It tells me, that i have opened to many files.

How do I tell my dear SAS NOT to open the produced PDF-files - but just produce them and leave these files untouched at my harddisk?

In story writing the rule is: Show it, don't tell it.

I want the opposite from my SAS: tell me, don't show me.

Can anyone help me?

Torben

Super Contributor
Posts: 276

Re: How can I explain SAS to Tell it - don't show it?

Hi,

Quick Question..

Was All PDF Documents openings in result Viewers in SAS or opening externally by Adobe reader ??

Thanks,

Sanjeev.K

Super Contributor
Posts: 578

Re: How can I explain SAS to Tell it - don't show it?

If you're using Enterprise Guide, there is an option that tells EG to "Automatically open data or results when generated".  Go to Tools>Options>Results General.

Super User
Posts: 19,867

Re: How can I explain SAS to Tell it - don't show it?

Same option in SAS 9.3/4 I believe.

Super User
Super User
Posts: 7,076

Re: How can I explain SAS to Tell it - don't show it?

Sounds like the setting default has been changed in your 9.4 installation over what you had in 9.3.

See if this paper still applies.  http://support.sas.com/resources/papers/proceedings12/250-2012.pdf

New Contributor
Posts: 2

Re: How can I explain SAS to Tell it - don't show it?

Thanks all of you Smiley Happy

I changed the preferences in Tools>Options>Preferences>results and unchecked the "View results as they are generated" - it worked perfectly.

Ask a Question
Discussion stats
  • 5 replies
  • 387 views
  • 0 likes
  • 5 in conversation