GPLOT is not giving me continues data

Reply
Frequent Contributor
Posts: 129

GPLOT is not giving me continues data

Hi,

my  GPLOT is not giving me continues data... as an example let's say if I have volumes for 10 days then the graph is showing Day1, day3, day5, day7, Day9... Here is the code that I've used...

may I know how to fix this issue

Thanks in advance

TITLE1 FONT='Arial/Bold' Height=2 JUSTIFY=CENTER "test";

SYMBOL1 INTERPOL=JOIN HEIGHT=10pt VALUE=NONE LINE=1 WIDTH=2 CV = _STYLE_;

SYMBOL2 INTERPOL=JOIN HEIGHT=10pt VALUE=NONE LINE=1 WIDTH=2 CV = _STYLE_;

SYMBOL3 INTERPOL=JOIN HEIGHT=10pt VALUE=NONE LINE=1 WIDTH=2 CV = _STYLE_;

SYMBOL4 INTERPOL=JOIN HEIGHT=10pt VALUE=NONE LINE=1 WIDTH=2 CV = _STYLE_;

SYMBOL5 INTERPOL=JOIN HEIGHT=10pt VALUE=NONE LINE=1 WIDTH=2 CV = _STYLE_;

SYMBOL6 INTERPOL=JOIN HEIGHT=10pt VALUE=NONE LINE=1 WIDTH=2 CV = _STYLE_;

SYMBOL7 INTERPOL=JOIN HEIGHT=10pt VALUE=NONE LINE=1 WIDTH=2 CV = _STYLE_;

SYMBOL8 INTERPOL=JOIN HEIGHT=10pt VALUE=NONE LINE=1 WIDTH=2 CV = _STYLE_;

SYMBOL9 INTERPOL=JOIN HEIGHT=10pt VALUE=NONE LINE=1 WIDTH=2 CV = _STYLE_;

Legend1 FRAME;

Axis1 STYLE=1 WIDTH=1 MINOR=NONE    label=(angle=90 rotate=0 FONT='Arial/Bold' justify=center 'Level');

Axis2 STYLE=1 WIDTH=1 MINOR=NONE    label=(f='Arial/Bold' justify=center 'Days');

PROC GPLOT DATA = WORK.Temp_Table

;

PLOT VOLUME * DAY_DATE =ID_CATEGORY /  VAXIS=AXIS1 HAXIS=AXIS2 FRAME LEGEND=LEGEND1;

format volume comma10.0;

RUN;

Trusted Advisor
Posts: 1,610

Re: GPLOT is not giving me continues data

Does SAS think the variable DAY_DATE is numeric or character?

Although the horizontal axis is Day 1, Day 3, Day 5, etc., that is consistent with a continuous variable (also consistent with a character variable). So how do you know it is not giving you a continuous variable?

What should the horizontal axis be?

Ask a Question
Discussion stats
  • 1 reply
  • 153 views
  • 0 likes
  • 2 in conversation