Error when accessing the metadata of a LASR library

Reply
N/A
Posts: 1

Error when accessing the metadata of a LASR library

Hi,

I have a problem when I try to update a table in Visual Analytic

I mention when I run the cod in Enterprise Guide everything works,

but when I try to run the cod from command line I have errors:

Below is the log:

126        / update lasr server *****/

127       

128        LIBNAME LASRLIB SASIOLA  TAG=VAPUBLIC  PORT=10031 HOST="sast1.site" SIGNER="http://sast2.site:7980/SASLASRAuthorization"

128      !  ;

NOTE: Libref LASRLIB was successfully assigned as follows:

      Engine:        SASIOLA

      Physical Name: SAS LASR Analytic Server engine on single host 'sast1.site', port 10031

129       

130        proc sql;

131           drop table lasrlib.lg_article_schedule_i;

ERROR: Unable to connect to Metadata Server.

ERROR: Write access to member LASRLIB.LG_ARTICLE_SCHEDULE_I.DATA is denied.

WARNING: Table LASRLIB.LG_ARTICLE_SCHEDULE_I has not been dropped.

NOTE: PROC SQL set option NOEXEC and will continue to check the syntax of statements.

132        quit;

NOTE: The SAS System stopped processing this step because of errors.

NOTE: PROCEDURE SQL used (Total process time):

      real time           0.00 seconds

      cpu time            0.01 seconds

     

133       

134        data LASRLIB.lg_article_schedule_i;

135           set myfiles.lg_articles20150123;

136        run;

ERROR: Unable to connect to Metadata Server.

ERROR: Write access to member LASRLIB.LG_ARTICLE_SCHEDULE_I.DATA is denied.

NOTE: The SAS System stopped processing this step because of errors.

NOTE: SAS set option OBS=0 and will continue to check statements. This might cause NOTE: No observations in data set.

NOTE: DATA statement used (Total process time):

      real time           0.00 seconds

      cpu time            0.00 seconds

Can someone help me?

Thank you.

New Contributor
Posts: 2

Re: Error when accessing the metadata of a LASR library

I'm seeing the same thing.  Any solutions?  It's like we are not connecting to the Metadata Server properly when using the command line...

SAS Employee
Posts: 340

Re: Error when accessing the metadata of a LASR library

Yes. Check your metadata connection settings.

proc options group=meta;run;

New Contributor
Posts: 2

Re: Error when accessing the metadata of a LASR library

I got this little tidbit from my install consultant for creating the connection to the metadata in the code.  Works great.

options metapass="XXXXX" metaport=8561 metaprotocol=bridge metarepository="Foundation" metaserver="host.domain" metauser="userid";

Contributor
Posts: 43

Re: Error when accessing the metadata of a LASR library

Thank you so much, it worked perfectly!

Ask a Question
Discussion stats
  • 4 replies
  • 2419 views
  • 1 like
  • 4 in conversation