Error in the LIBNAME statement

Reply
Frequent Contributor
Posts: 101

Error in the LIBNAME statement

When I run the SAS DI jobs,I am gettin this error in table loader.

ERROR: Unable to clear or re-assign the library TESTREF because it is still in use.

ERROR: Error in the LIBNAME statement.

When we will get this error and What is  tis ?

How to clear this?

Super User
Posts: 5,426

Re: Error in the LIBNAME statement

Posted in reply to Helannivas

You can ignore this, since it probably would not affect the job, especially not when the job is deployed and being executed via the Batch Server.

In order to get rid of the error in DIS, just close and reopen the job (will start a new workspace server).

Data never sleeps
Frequent Contributor
Posts: 101

Re: Error in the LIBNAME statement

Thanks LinusH for ur reply...wen i closed and reopend the job its working fine....

I have one more doubt.

When I am using  data validation transformation,I have given error table name.(libref.error table name)

Sometimes,its working fine and sometimes its showing error like this.

ERROR attempting to CREATE a DBMS table.ERROR: CLI execute error:[Dataflux][ODBC Oracle Wire]

What is tis?I cant proceed further.

Pls help

Super User
Posts: 5,426

Re: Error in the LIBNAME statement

Posted in reply to Helannivas

Is the table you specified an oracle table? Sounds like lack of permissions of some sort. Need more details to help you out (such as a more complete log, and the libname statement).

Data never sleeps
Frequent Contributor
Posts: 101

Re: Error in the LIBNAME statement

Hi LinusH,

In Data Validation Transformation(SAS DI job),I am getting the same error  "Libname is not assigned.

I hv closed the job and run that job again and its working fine.

whether we need to clear that library before running the job?

And,whenever I try to deploy the job for scheduling .I am not able to do so.

I am getting the error as "Unable to save the metadata".

What action I need to take for these.Kindly provide solution for my question.

Super User
Posts: 5,426

Re: Error in the LIBNAME statement

Posted in reply to Helannivas

Ok, "Libname is not assigned" is not the same error.

My guess here (some log would help...) is that you specified an error table in the transformation, and it reside in a library that is not pre-assigned. Since this is an old transformation, and less metadata-driven than you could assume, you need to assure that any libref referenced on these tabs are being assigned (hard coded, autoexec, whatever).

When you deploy a job for scheduling, you need write access to Foundation and the folders where your job and deployed jobs metadata resides. My guess (again) is that you are working in project repository, and then your user has limited rights in Foundation. Talk to you metadata administrator how to handle this scenario. Could be that you need another metadata user to do deploy, or that deploy will be done by a different (such as a release responsible person or administrator).

Data never sleeps
Ask a Question
Discussion stats
  • 5 replies
  • 1484 views
  • 0 likes
  • 2 in conversation