Enabling X command for SAS JOB

Reply
Occasional Contributor
Posts: 9

Enabling X command for SAS JOB

Hello,

We are deploying a SAS Job having x command within the SAS Code.The job is executed on SAS Data step batch server. To enble the X command in the job we have made following changes:

1. Enabled X command from SAS Mangement console for SAS App.

2. Enabled X command for Object spawner by specifying -allowxcmd in Objectspawner.sh file.

But in sasbatch.sh its not taking -allowxcmd option

Kindly guide us that how can we enable X command for SAS Data Step Batch Server.

Regards,

Rakshit Shah

Super Contributor
Posts: 282

Re: Enabling X command for SAS JOB

Posted in reply to rakshit_shah

Hi,

When you say "not taking" what do you mean by this? Is there an error message or warning message? If yes, then please share the message(s) so that someone might be able provide an answer.

Is the following relevant to what you are trying to do:

SAS(R) 9.2 Intelligence Platform: Desktop Application Administration Guide

If you're not getting the help you need then it might be worth contacting SAS Technical Support using the link at the bottom of this page.

Regards,

Amir.

Trusted Advisor
Posts: 1,301

Re: Enabling X command for SAS JOB

There is no option called allowxcmd outside of the management console gui and it is not part of SAS Data Step Batch Server.

There is no option for the ObjectSpawner for -allowxcmd that should be removed.

You should edit you sasbatch.sh file and instead of -allowxcmd, just put -xcmd, the correct option name.

You should be seeing error's the way you have it setup now that you are passing bad options, if you are not, I am surprised.

Ask a Question
Discussion stats
  • 2 replies
  • 749 views
  • 0 likes
  • 3 in conversation