ECM & AML not available for configuring compute server.

Reply
SAS Employee
Posts: 4

ECM & AML not available for configuring compute server.

Dear All,


We are trying to implement the AML 5.1 with the new depot and new plan file provided.

The AML 5.1 & ECM are installed properly without any errors but while configuration the config file in the SASFoundation/9.3/../.. directory for the products ECM and AML are not available and hence not able to proceed further.

I doubt the correctness of the plan file again since it is a plan based deployment.

If not let me know the root cause of the issue and help us to proceed further.


The error message is given for your reference.


I like to know why this config directory  related to AML and ECM are missing in SASFoundation eventhough the installation is successful.


Please note the environment is a current environment and we are trying to add ECM and AML 5.1 in existing metadata.


Rgds,

Ezhil

Valued Guide
Posts: 3,206

Re: ECM & AML not available for configuring compute server.

Ezhil, AML and ECM are solutions on top of the enterprise intelligence environment. (Metadataserver BI-server DI-server Portal midtier).
You have read or redirected the installation instructions to do all those parts. (users ports startup etc)
It can be seen as 1/ Installation of SAS (foundation) and tools 2/ configuring and running Eip 3/ adding the solution (AML ECM) on top of it.

All these step can be done as "setup" with a plan file. In that you will miss the verification of those partial steps.

By know your message is clear. If you are uncertain how to proceed.... contact TS. (did you?)  

---->-- ja karman --<-----
SAS Employee
Posts: 4

Re: ECM & AML not available for configuring compute server.

Jaap,

I contacted TS and waiting for 3 days for their reply. (Track # SAS 7611295762).

My understanding is SAS depot is not having the product related directories.

But depot checker utility given green signal, either it may missed to copy while installation.

Attaching the deployment registry for review.

Rgds,

Ezhil

Attachment
Valued Guide
Posts: 3,206

Re: ECM & AML not available for configuring compute server.

Your last error is a configuration error ....    
Not getting support as expected is not nice. Try to understand all technical steps to get it up and running and do as much possible to analyze where the issues are.
I avoide the word installation because for a project manager this all is the installation. He does not know better, should be helped to understand.

Your deployment-registry and software-order and software depot is reflecting what is copied-pasted to machines.  
For techies that is the installation part.   
You added JBOSS as 3-party component it belongs to that. There is always some uncertainty on versions fixes dependicies.
With a 9.4 you will get the VMware fabric tools included.  

The next part is the configuration step, Giving port-numbers dns-adresses users passwords as described and requested.
This is generating a lot of scripts for all additional steps.  Several are interacting to each other.

Many are doing updates in the metadatabase using the SAS metadataserver.
As soon you can run the metadataserver check that one (analyse those logs)

As soon you can run the webserver check that one (analyse those logs)

Than proceed with the detailed solutions. 

It is in this part you have the error message. It is stopped saying a configuration file is not there.

It could be caused by malfunction of the SAS metadata server or webcontainer (jboss).
Check the logs of those steps.
It gives the impression you can proceed and try this step later again when the root cause is solved.

 
 

---->-- ja karman --<-----
Ask a Question
Discussion stats
  • 3 replies
  • 316 views
  • 0 likes
  • 2 in conversation