Connect to SQLSVR( DATAsrc="&varName") ... won't connect

Accepted Solution Solved
Reply
Contributor
Posts: 47
Accepted Solution

Connect to SQLSVR( DATAsrc="&varName") ... won't connect

When I do this I get the error: "Data source name not found and no default driver specified" ... it's as if it is not resolving the variable &varName to the valid DSN that it contains.  Is there a way to connect in this fashion?

 


Accepted Solutions
Solution
‎04-02-2018 10:38 AM
Contributor
Posts: 47

Re: Connect to SQLSVR( DATAsrc="&varName") ... won't connect

Using datasrc=&varname, and defining the varname to include the quotes worked.

View solution in original post


All Replies
Valued Guide
Posts: 530

Re: Connect to SQLSVR( DATAsrc="&varName") ... won't connect

Without the full code and logs there's no way of telling. Please run your program with OPTIONS MPRINT SYMBOLGEN; and provide us the details. Also, make sure it's formatted properly by pasting into a code segment (click on the {i} or running man icon).

 

And to test your connection I would suggest to insert the proper values verbatim instead of via a macro var reference. If that works you can take the next step and use macro's.

 

Regards,

- Jan.

Solution
‎04-02-2018 10:38 AM
Contributor
Posts: 47

Re: Connect to SQLSVR( DATAsrc="&varName") ... won't connect

Using datasrc=&varname, and defining the varname to include the quotes worked.
☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 2 replies
  • 131 views
  • 0 likes
  • 2 in conversation