Batch mode missing

Reply
New Contributor PA
New Contributor
Posts: 4

Batch mode missing

Hi,

I do not have Run In Batch mode in the context menu. I right click and the option is missing from the menu...

Any suggestion?

I am running SAS 9.3 in W7 64 bits.

Thanks in advance

PA

Super User
Posts: 7,429

Re: Batch mode missing

In which context menu should that selection be?

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
Super User
Super User
Posts: 7,716

Re: Batch mode missing

I think he refers to right clicking on a .SAS program in Windows, and choosing batch submit.  It should be setup automatically with the SAS install.  Did you do the install yourself, is it locally installed etc?  This will only appear on local install SAS. 

Frequent Contributor
Posts: 144

Re: Batch mode missing

Hi,

When I want to run a SAS program on batch mode I select open with "SAS 9.3 for windows" and is runned in batch mode.

Super User
Super User
Posts: 7,716

Re: Batch mode missing

That's odd.  Been a few years since I had local install SAS, but I remember having at least two options, open with SAS System, and Run In Batch.  I would imagine different setups have different options though.  I would suggest the OP checks the install + guidance for install and if necessary contact support.

Super User
Posts: 7,429

Re: Batch mode missing

Can you start SAS by Clicking Start - All Programs - SAS - SAS 9.3?

Or do you use SAS EG to write your SAS codes, in which case I suggest you open your server list in EG and right-click on the active server to view its properties. If no "Local" server is present, then you do not have SAS locally installed, and won't be able to run SAS codes in batch mode on your desktop, only on the SAS server.

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
New Contributor PA
New Contributor
Posts: 4

Re: Batch mode missing

Hi guys, yes I am referring to the windows explorer context menu. I used to have the 2 options (open and run in batch) and now I have none! It is a local instalation.

I have tried the option "Manage SAS File Types" and nothing...

thanks.

Ask a Question
Discussion stats
  • 6 replies
  • 387 views
  • 0 likes
  • 4 in conversation