Security Intelligence to prevent fraud, achieve compliance and preserve security.

Document upload failing after SSL implementation

Reply
Contributor
Posts: 22

Document upload failing after SSL implementation

Hi,

SAS 9.3/AML5.1

When we try to upload a document in the AML UI, we get the below error .This was working fine prior to SSL implementation , we could upload and view the documents.

However once SSL was implemented, we are unable to upload documents or view  the old documents that was uploaded before SSL.

We receive the below error during upload :

Failed to create folders in DAV: Previously failed to connect to https://ant1amlwebs01.banktst.ae:8443/SASContentServer/repository/default/sasdav for sastrust@saspw

In SMC , all the names have been updated to full host name.

In jboss server start .sh files too we have updated the host.

If opened in a separated IE, the above link opens correctly.

I am also able to access the http://serverSmiley Tongueort/SASContentServer/dircontents.jsp page seperately.

In SMC, webdav properties has the “secure” checkbox checked in the below services:

  • Remote Services
  • SASBIPortlet4.3 Local Services
  • SASJSR168RemotePortlet4.3 Local Services
  • SASPackageViewer4.3 Local Services
  • SASPortal4.3 Local Services
  • SASStoredProcess9.3 Local Services
  • SASWebReportStudio4.3 Local Services

Let us know what could be the issue here.

Trusted Advisor
Posts: 1,321

Re: Document upload failing after SSL implementation

Posted in reply to Anand6666

You may need to complete some manual configuration tasks as outlined at 55513 - Attempting to create a custom theme might return the error "Failed to create folders in DAV" - the issue isn't exactly the same situation as yours however the error message also relates to WebDAV. If you look at the Manual Configuration Task link the usage note refers to, it is what is required when changing from HTTP to HTTPS.

Hope this helps!

Kind Regards,

Michelle

Contributor
Posts: 22

Re: Document upload failing after SSL implementation

Posted in reply to MichelleHomes

Hi Michelle,

I tried and checked the manual steps available , for HTTPS conversion. checked the hostnames and Secure checkbox in SAS Foundation Services , validated the SAS content settings from SMC, checked the SSL certificates but still unable to upload documents.

our environment without SSL can upload documents, its only after implementing SSL that we are facing this issue.

Is there any other alternatives . Have contacted the SAS support but they are taking time and we need to resolve this at the earliest as this is showstopper for our GOLIVE.

All the help is appreciated Smiley Happy

Community Manager
Posts: 408

Re: Document upload failing after SSL implementation

Posted in reply to Anand6666

Hi, this is Shelley Sessoms, the community manager for the admin and deployment community. I see there is some recent activity on your tech support track. Since this is an AML deployment, you're doing the right thing. AML takes specialized support and often longer time to resolve. Thanks for using the community and also for opening a track. I feel confident you'll get the help you need from tech support.

Ask a Question
Discussion stats
  • 3 replies
  • 481 views
  • 3 likes
  • 3 in conversation