Got ideas for this community? Share them here.

Comments
by Community Manager
on ‎10-25-2017 10:23 AM

Thanks for the suggestion @ChrisBrooks.  If you're assuming that SAS University Edition can't reach a GitHub repo (because of HTTPS), that's not the case.  It's true that SAS (running on the virtual machine, with SAS/SECURE components not installed) cannot access HTTPS sites via FILENAME URL or PROC HTTP.  But SAS Studio is running in your browser, and as long as you can navigate to GitHub, then you can add a GitHub site as a repository in SAS Studio within SAS UE.

 

Here's my SAS UE with tasks from github.com/sassoftware:

 

sas_ue_ct.png

 

In my Preferences:

 

repos.png

by Valued Guide
on ‎10-25-2017 07:14 PM

Thanks @ChrisHemedinger - I think  I realised what happened when I initially tried to add the repository as I just tried again and got an error (the message said the repository couldn't be validated). So I deleted it and tried yet again and finally realised that when I copied the URL there were extra spaces at the start and of the string. So I removed them and it all worked fine!

by Community Manager
on ‎10-26-2017 08:03 AM
Status changed to: Implemented

Based on this exchange, I'll mark this as Implemented.  We use that GitHub repo as a place to share sample (and useful!) custom tasks that we have developed, but I think we would welcome other contributions!

by Valued Guide
‎10-26-2017 09:19 AM - edited ‎10-26-2017 09:19 AM

Thanks @ChrisHemedinger that's good to hear - feel free to use any tasks I may contribute to the Community Library Smiley Happy