Community talk about communities.sas.com. Meta!

Spell checking not enabled in SAS Communities??

Reply
Respected Advisor
Posts: 3,050

Spell checking not enabled in SAS Communities??

When I make an obvious typo in the SAS Forums, no indication is given that this is a spelling error.

 

When I make the same obvious typo in the Adobe Forums, the improperly spelled word is underlined indicating that the word is misspelled.

 

I attach two screen captures, one from SAS Communities, the other from Adobe Forums, where in each case the misspelled word is "ovservations"

 

Is there something wrong with my browser (Chrome 61.0 on Windows 7)? Or is this a feature that is not available in the SAS  Communities?

 

The Adobe screen capture is first, the SAS screen capture is second.

 

adobe_forums.pngsas_communities.png

 

--
Paige Miller
Super User
Posts: 23,758

Re: Spell checking not enabled in SAS Communities??

Posted in reply to PaigeMiller

Not an answer but a workaround, you can click the little ABC button on the end to have it underlined red.

I would also prefer if it was set by default.

Community Manager
Posts: 3,436

Re: Spell checking not enabled in SAS Communities??

Try now.  I've switched the "message editor" checker off, and the browser-based checker should kick in. That's probably what you see in other forums.

Super User
Posts: 13,574

Re: Spell checking not enabled in SAS Communities??

Posted in reply to PaigeMiller

I suppose if most of the users actually would post code into either of the code boxes this might make more sense but spellcheckers and code syntax seldom seem to get along.

 

Super User
Posts: 23,758

Re: Spell checking not enabled in SAS Communities??


ballardw wrote:

I suppose if most of the users actually would post code into either of the code boxes this might make more sense but spellcheckers and code syntax seldom seem to get along.

 


As long as it doesn't auto correct - that's annoying.

 

@ChrisHemedinger And yes, incorrectly typed words are now being underlined automatically, including your name Smiley Happy 

 

 

Respected Advisor
Posts: 3,050

Re: Spell checking not enabled in SAS Communities??

Ok, thank you, @ChrisHemedinger, that's better! But I suspect people will now see their SAS Code underlined and will complain. So I guess there's no universal solution. Smiley Sad

 

 

--
Paige Miller
Super User
Posts: 13,574

Re: Spell checking not enabled in SAS Communities??

Posted in reply to PaigeMiller

PaigeMiller wrote:

Ok, thank you, @ChrisHemedinger, that's better! But I suspect people will now see their SAS Code underlined and will complain. So I guess there's no universal solution. Smiley Sad

 

 


I was sort of hoping this would be another place where the main message windows are treated differently then the code boxes, with spell check ignoring the code box. Maybe they can find another option to set. Hint @ChrisHemedinger?

Super User
Super User
Posts: 8,116

Re: Spell checking not enabled in SAS Communities??

does this automagically highlight missspelled words?

data MRSA  ;
  x='Does this highlight automagically?' ;
run;

Looks like it checks both the code and text.

image.png

Community Manager
Posts: 3,436

Re: Spell checking not enabled in SAS Communities??

Alas, there isn't such granular control at the communities site level.  But we might be able to find a way -- I'll look into it.

 

I think we agree that it's better to have the spellcheck on, correct?  Basically the current setting simply allows the browser-based spellcheck to do its thing.  Before I changed it, it was suppressed in the message editor.  General best practice (from what I've read) is to allow the browser spellcheck.  The setting we had before is an option for legacy, as browser spellcheckers weren't always as good as they are today.

Community Manager
Posts: 3,436

Re: Spell checking not enabled in SAS Communities??

@Reeza - time to right-click, add me to your dictionary!

 

sc.png

Ask a Question
Discussion stats
  • 9 replies
  • 346 views
  • 6 likes
  • 5 in conversation