Community talk about communities.sas.com. Meta!

Forum is eating my code

Reply
Super User
Posts: 23,778

Forum is eating my code

I know I'm a 'power user' and others may not be having the same issues. but this one is happening multiple times and I initially assumed I was just hitting Post too soon or something. 

 

Anyways, I add the code in to the answer (image1) and then when it posts the code is gone Smiley Sad (image 2). 

 

delete code.PNGdelete_code2.PNG

 

 

Community Manager
Posts: 725

Re: Forum is eating my code

Hi @Reeza,

 

I've tested this out on our community stage environment and it's working fine. We're looking into this though and will get back to you.

 

Best,

Anna

Super User
Posts: 23,778

Re: Forum is eating my code

Posted in reply to AnnaBrown

It's not happening all the time, but it's definitely occurring. It happened twice on the post indicated so I was able to take screenshots of it.

Super User
Super User
Posts: 8,127

Re: Forum is eating my code

Have you tried different browsers?

Does in happen only when you are making quick changes?  Perhaps closing the pop-up and then immediately hitting the post button?

 

I find that sometimes the editor page takes a little time to figure things out. It appears to have opened the post for editing and I try to start typing and then I look and it has reformatted the page and the cursor is in a new place that the things I typed are not where I wanted them.

 

 

Super User
Posts: 23,778

Re: Forum is eating my code

[ Edited ]

@Tom Yes, this has happened on multiple browsers, Safari (iPad), Safari(MacBook), Chrome(Windows 7).  

 

The pop up and wait may be an important caveat. I'll see if I can replicate it with that. 

 

this is my new test code.

EDIT: ok, pressed it almost instantaneously and it posted here...the fact that it happened repeatedly on that previous post is confusing to me. I tried three times editing that one. 

Super User
Posts: 10,787

Re: Forum is eating my code

Maybe "or" is a special word . Try to get rid of it .

PROC Star
Posts: 8,169

Re: Forum is eating my code

I don't have an answer, but am just testing a possibility:

x=test;
run;

or

extra lines of
code
PROC Star
Posts: 8,169

Re: Forum is eating my code

test2

data have;
  set test;

or

data extra;
  set lines;
Community Manager
Posts: 3,442

Re: Forum is eating my code

Let us know if this is still happening @Reeza.  If so...well, I'll see you on Monday night or Tuesday at least and we'll take a look.

 

Alberta-bound Chris

Ask a Question
Discussion stats
  • 8 replies
  • 393 views
  • 6 likes
  • 6 in conversation