Community deutschsprachiger SAS-Anwender und -Programmierer

Antworten
Dies ist eine offene Gruppe. Melden Sie sich an und klicken Sie auf die Schaltfläche „Gruppe beitreten“, um Mitglied zu werden und damit zu beginnen, Beiträge in dieser Gruppe zu veröffentlichen.
Highlighted
Frequent Contributor
Beiträge: 121
Enterprise Guide 4.1 und 4.2: Totgesagte leben länger

Ich hoffe von ganzem Herzen, dass dieser Beitrag Sie nicht betrifft. Aus zuverlässiger Quelle weiß ich jedoch, dass auch im Jahr 2015 noch einige Kunden mit SAS 9.1 und Enterprise Guide 4.1 arbeiten.

Das ist wirklich erstaunlich, da EG 4.1 nur unter Windows XP und Vista lauffähig ist und sich bereits unter Windows 7 nicht mehr installieren lässt.

Was die wenigsten EG Anwender wissen: EG hat ein eingebautes Verfallsdatum! Siehe Usage Note: 33359 - SAS® Enterprise Guide® Expiration Dates

Ab diesem Verfallsdatum lässt sich EG nicht mehr starten und bricht mit der Fehlermeldung "Diese Version von SAS Enterprise Guide ist am ... abgelaufen".

Dieser Tag X war bereits am 1.12.2010

Ich kann mich noch gut daran erinnern: unglückliche Anwender und unter Zeitdruck schnell einen Hotfix für das Rollout packetieren. SAS hatte als letztes Lebenszeichen dafür, dass EG 4.1 noch supported wird den Hotfix 41EG17 herausgebracht, der das Ablaufdatum noch einmal um 5 Jahre verlängerte.

5 Jahre? Das heißt ja, dass es dieses Jahr wieder soweit ist!! Und so ist es auch. Das Ablaufdatum beläuft sich nun auf den 1.12.2015. Ab dann wird auch der gepatchte EG 4.1 nicht mehr starten.

Zum Glück gibt es aber seit einem halben Jahr einen neuen Hotfix 41EG18, der den "Patienten" noch weitere 5 Jahre im Wachkoma am Leben hält. Ich habe ihn bereits in einer VM installiert und getestet. Solange man die Betriebssystem-Zeit nicht auf 2021 stellt, startet der EG problemlos. Ansonsten erhält man wieder diese frohe Fehlermeldung:

PS: auch EG 4.2 wird diesen Dezember den Dienst quittieren.

Höchste Zeit also einmal zu prüfen, wann ihr EG abläuft und bei Ihrem SAS Administrator nach dem neuesten Hotfix zu fragen.

Wie gesagt: ich hoffe dieser Beitrag betrifft Sie nicht. Alle anderen empfehle ich aktiv zu werden!

- Andreas Menrath

Frequent Contributor
Beiträge: 121
Re: Enterprise Guide 4.1 und 4.2: Totgesagte leben länger

Vielleicht mach auch dieser Beitrag hier, Lust auf eine neuere EG Version umzusteigen:

Obwohl EG 7.1 für SAS 9.4 optimiert wurde, werden aber auch noch die älteren SAS Server Versionen 9.2 und 9.3 unterstützt.

New Contributor
Beiträge: 2
Re: Enterprise Guide 4.1 und 4.2: Totgesagte leben länger

Danke für den Hinweis.
Wir haben teils noch den EG 4.1 laufen.

Durch ein Verstellen vom Systemdatum kamen wir darauf,

daß wir auch betroffen sind und der Hotfix noch nicht installiert ist.

Frage: Kann man das nur über so einen Test ermitteln oder lässt sich

der Hotfix-Stand auch anders ermitteln?

Laut Info im EG haben wir Version "SAS Enterprise Guide 4.1 (4.1.0.1009)"

Frequent Contributor
Beiträge: 121
Re: Enterprise Guide 4.1 und 4.2: Totgesagte leben länger

Gern geschehen.


Den Hotfixstand kann man aus der Versionsnummer ablesen, siehe: http://support.sas.com/kb/20/655.html

Ihr EG entspricht somit dem Hotfixstand 41EG09.


Viele Grüße,

Andreas Menrath