DATA Step, Macro, Functions and more

%sysexec UNC filepath

Accepted Solution Solved
Reply
Contributor
Posts: 45
Accepted Solution

%sysexec UNC filepath

I am attempting to copy files over to a different folder and am using the sysexec fuction. The issue that I am running into is my file paths is UNC so SAS keeps opening the CMD window and I have to manually exit for each file. Since there are 3500 files to transfer this isn't really a good option. Any suggestions to get SAS to exit for me? I could transfer the files over to my C: drive but I would put that as the last option. 

 

%let source=\\global\kcshares\Projects\110933\Police Reports\All Reports;
%let target=\\global\kcshares\Projects\110933\Police Reports\Curve Reports;

proc sql noprint;
	select report
	into :report separated by ' '
	from crashes;
quit;
%put &report;
%macro report;
%do i=1 %to 5; *%sysfunc(countw(&report," "));
	%let report_no=%scan(&report,&i," ");
		%sysexec copy "&source.\&report_no..pdf" "&target.\&report_no..pdf"; 
%end;
%mend;
%report;

Untitled.png


Accepted Solutions
Solution
‎04-18-2017 03:02 PM
Contributor
Posts: 45

Re: %sysexec UNC filepath

[ Edited ]

I found the solution I needed to use:

 

options NOXWAIT;

View solution in original post


All Replies
Solution
‎04-18-2017 03:02 PM
Contributor
Posts: 45

Re: %sysexec UNC filepath

[ Edited ]

I found the solution I needed to use:

 

options NOXWAIT;

Super User
Posts: 10,483

Re: %sysexec UNC filepath

If you were copying all of the files with common name you can use wildcards such as

 

copy "&source.\rep*.pdf" would copy all files that start with the letters 'rep'. Or if you needed all of the PDF files then *.pdf

 

So you may not have needed to copy them one by one.

 

 

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 2 replies
  • 123 views
  • 1 like
  • 2 in conversation