DATA Step, Macro, Functions and more

sas 9.2 batch submit not working

Accepted Solution Solved
Reply
Contributor
Posts: 45
Accepted Solution

sas 9.2 batch submit not working

Hello all,

So my batch submit is not working. I try running a program in batch mode and I get no log/list. By the way, I’m using SAS 9.2 and there is also SAS EG 4.3 on XP pro.

Here’s how it’s setup under windows explorer:

Under Folder Options -> File Types, the “Details for SAS extension” is being open with “The SAS System for Windows”. When I click into Advanced, go into actions and click edit for “Batch Submit with SAS 9.2”, the Action shows “&Batch Submit with SAS 9.2”. The section called “Application used to perform action” says:

"C:\Program Files\SAS92\SASFoundation\9.2\core\sasexe\sasoact.exe" "%1" -nologo -config C:\PROGRA~1\SAS92\SASFOU~1\9.2\SASV9.CFG

Use DDE is marked.

There’s nothing for “DDE message”.

Application: sasoacct

There’s nothing for “DDE application Not Running”

Topic is set to System

****************

I have tried other combinations for “Application used to perform action” without luck.

What am I missing? Is this an IT issue? Is there anything else I can try to make batch submit work?

Your help is greatly appreciated. Thanks!

Alex


Accepted Solutions
Solution
‎11-13-2013 09:27 AM
Trusted Advisor
Posts: 2,116

Re: sas 9.2 batch submit not working

your SAS file associations may not be set correctly.  See

32464 - Registering file types via the SAS File Type Management Tool for SAS® 9.2, SAS® 9.3, and SAS...

for how to reset them.

If that doesn't work, then a call to tech support may be in order.

One thing that has recently cause a lot of us to have "SAS Headaches" is our local IT groups "upgrading" to Java 7 and not telling users that they have done it (particularly bad if the rip out all older versions of Java!).  Pieces of SAS just stop working.  If you open interactive SAS and get an error message about Java, that is the most likely scenario.

Doc Muhlbaier

Duke

View solution in original post


All Replies
Solution
‎11-13-2013 09:27 AM
Trusted Advisor
Posts: 2,116

Re: sas 9.2 batch submit not working

your SAS file associations may not be set correctly.  See

32464 - Registering file types via the SAS File Type Management Tool for SAS® 9.2, SAS® 9.3, and SAS...

for how to reset them.

If that doesn't work, then a call to tech support may be in order.

One thing that has recently cause a lot of us to have "SAS Headaches" is our local IT groups "upgrading" to Java 7 and not telling users that they have done it (particularly bad if the rip out all older versions of Java!).  Pieces of SAS just stop working.  If you open interactive SAS and get an error message about Java, that is the most likely scenario.

Doc Muhlbaier

Duke

Contributor
Posts: 45

Re: sas 9.2 batch submit not working

Hi Doc@Duke,

the instruction in the link did the trick. Batch submit works now. I appreciate the heads up on Java updates.

Thank you for your assistance!

Alex

🔒 This topic is solved and locked.

Need further help from the community? Please ask a new question.

Discussion stats
  • 2 replies
  • 441 views
  • 1 like
  • 2 in conversation