DATA Step, Macro, Functions and more

noquotelenmax

Accepted Solution Solved
Reply
Respected Advisor
Posts: 3,886
Accepted Solution

noquotelenmax

The SAS default is "quotelenmax". I run regularly into cases where I have to specifically define "options noquotelenmax;"

Do you know of any reason why I shouldn't set the default to "noquotelenmax" eg. via an option statement in the autoexec?


Accepted Solutions
Solution
‎05-21-2013 10:36 AM
PROC Star
Posts: 7,356

Re: noquotelenmax

: Methinks you have been lucky or don't do a lot of coding which involves quoting.  I, personally, have often received the warning and knew to search code for unbalanced quotation marks.

View solution in original post


All Replies
PROC Star
Posts: 7,356

Re: noquotelenmax

: If you write code, I would leave it set to its current default.  However, when you are running already tested code, I don't see any problem using option statements, before and after the code, switching between the two values.

Respected Advisor
Posts: 3,886

Re: noquotelenmax

Hi Art

Turning "quotelenmax" on and off is what I'm currently doing.

But I'm just wondering where the warning when "quotelenmax" is set adds any value. I simply can't remember any case I've encountered where the warning actually pointed to a real issue. But may-be I was just lucky.

Thanks

Patrick

Solution
‎05-21-2013 10:36 AM
PROC Star
Posts: 7,356

Re: noquotelenmax

: Methinks you have been lucky or don't do a lot of coding which involves quoting.  I, personally, have often received the warning and knew to search code for unbalanced quotation marks.

Respected Advisor
Posts: 3,886

Re: noquotelenmax

Hi Art

Very valid point. So I continue doing what I'm doing without changing the default.

Thanks

Patrick

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 4 replies
  • 216 views
  • 3 likes
  • 2 in conversation