DATA Step, Macro, Functions and more

What's happened? dataset _toy

Reply
N/A
Posts: 1

What's happened? dataset _toy

data _toy;

X=1;

run;

LOG is noProblem.

But any dataset appear  my WORK library.

why?

Super User
Posts: 5,260

Re: What's happened? dataset _toy

What do you mean "any"? What is the problem?

6data _toy;
7    X=1;
8run;

NOTE: The data set WORK._TOY has 1 observations and 1 variables.

NOTE: DATA statement used (Total process time):

  real time       0.00 seconds
  cpu time        0.01 seconds
Data never sleeps
Super Contributor
Posts: 543

Re: What's happened? dataset _toy

Are you thinking of a data _NULL_ step?

Which I am not sure it makes sense with just x = 1;

Anca.

Super Contributor
Posts: 282

Re: What's happened? dataset _toy

Hi,

Please show us the log with the data step and the messages that say it is created.

Has the "user" option been set to value that is not "work"?

Are you running anything before this data step?

Regards,

Amir.

Super Contributor
Posts: 282

Re: What's happened? dataset _toy

Hi,

I have just run the data step in PC SAS 9.1.3 and it ran cleanly, but I too cannot see the "_toy" data set listed in the work library, although I can view it by issuing the "fsv _toy" command.

I tried the same data step on Mainframe Z/OS SAS 9.1.3 and again it ran cleanly and the "_toy" data set *is* listed in the work library and can be viewed.

What platform and version of SAS are you using?

May be something for SAS Technical Support.

Regards,

Amir.

Ask a Question
Discussion stats
  • 4 replies
  • 229 views
  • 0 likes
  • 4 in conversation