DATA Step, Macro, Functions and more

Sysencoding

Reply
Contributor
Posts: 26

Sysencoding

Hello, 

 

I need to change &sysencoding  from 'wlatin1' to 'UTF-8'  so that sas will keep Japanese characters 'as is ' and not change to question marks (ie ???)

Caveat : I only want to do it for one program not the entire system. 

Can anyone help me out with the code to accomplish this?

 

thanks!

PROC Star
Posts: 2,311

Re: Sysencoding

Have you tried the inencoding= and outencodinglibname options?

Super User
Super User
Posts: 7,932

Re: Sysencoding

How are you currently running your SAS programs?

If you are created .sas files and running them from the command line then add the -encoding option to the command line.

Or better still create two different commands that you use to run SAS.  One to use WLATIN1 and another to use UTF-8.  For example on our systems we have both a sas94 and a sas94_u8 command.

 

Regular Contributor
Posts: 201

Re: Sysencoding

If a sas workspace Server ist involved, you have to talk to the admins. They have to add a sasapp definition with using the appropriate configs.
Ask a Question
Discussion stats
  • 3 replies
  • 151 views
  • 2 likes
  • 4 in conversation