DATA Step, Macro, Functions and more

Search facility on PDF report is requiring spaces between characters.

Reply
N/A
Posts: 0

Search facility on PDF report is requiring spaces between characters.

Hi,

I have created a .lst file with the data by using the sas code and then I have created a .ps file by using the following code and then I converted the RPTFILE1.ps to RPTFILE1.pdf by using the Adobe Distiller.

FileName WanRpt "SASTEXT/file1.lst";

filename gsasfile "SASOUTPUT/RPTFILE1.ps";

%let fontnm =hwpsl001; /*Courier font used on report*/

goptions reset=all;
goptions device=psll norotate
hpos=132 vpos=61
ftitle=&fontnm ftext=&fontnm
noprompt
gaccess=gsasfile gsfmode=replace gend='0D0A'X gsflen=80;
run;

proc gprint fileref=WanRpt;
title1 h=.5 ' ';
run;


Problem:-In the RPTFILE1.pdf report the search facility is not working properly.For example if we search for a Item like "ABCD1234" in the report then it's not working. If you give the spaces between the characters like "A B C D 1 2 3 4" then it's working fine.

I thought that it might be a problem with the "device=psll"
option, So that I have chaged that to "device=psl" then the report structure is disturbing but we could not found the search problem.

So I rotate the report using "device=psl rotate=landscape" then the structure of the report is ok but getting the same search problem. I tried with all post script devices in sas but not.

If I changed the font to "hwpsl005" then the search problem is not appearing but the report structure is disturbing.

Could any one please suggest me on this. I am in the trouble with this.

Thanks,
Aruna. Message was edited by: Aruna
N/A
Posts: 0

Re: Search facility on PDF report is requiring spaces between characters.

Posted in reply to deleted_user
Please let me know if you have any questions and please help me to resolve this issue. Message was edited by: Aruna
SAS Super FREQ
Posts: 8,864

Re: Search facility on PDF report is requiring spaces between characters.

Posted in reply to deleted_user
Hi:
Ultimately, I suggest you work with Tech Support on this issue. A previous forum posting contains some links that might be useful, too:
http://support.sas.com/forums/thread.jspa?messageID=16386䀂

cynthia
Ask a Question
Discussion stats
  • 2 replies
  • 127 views
  • 0 likes
  • 2 in conversation