DATA Step, Macro, Functions and more

%SYSMEXECNAME eats blanks somehow?

Accepted Solution Solved
Reply
PROC Star
Posts: 1,433
Accepted Solution

%SYSMEXECNAME eats blanks somehow?

Hi All,

 

I've been using %SYSMEXECNAME() to get the name of currently executing macros, and noticed today that if I have text, then a blank, then a call to %SYSMEXECNAME(), the blank disappears.   Does this make any sense? 

 

I can work around it by using a quoted blank, %STR( ).  But it was a surprise to me.  I can't think why the blanks would disappear.

 

%macro test;
  %put There should be one space after colon but there are none: %sysmexecname(1);
  %put There should be three spaces after colon but there are none:   %sysmexecname(1);
  %put A quoted blank will work:%str( )%sysmexecname(1);
  %put SYSMACRONAME works fine: &sysmacroname;
%mend;
%test;

 

Returns:

There should be one space after colon but there are none:TEST
There should be three spaces after colon but there are none:TEST
A quoted blank will work: TEST
SYSMACRONAME works fine: TEST

Accepted Solutions
Solution
‎10-09-2017 07:42 AM
Super User
Super User
Posts: 7,860

Re: %SYSMEXECNAME eats blanks somehow?

[ Edited ]

I raised this issue with SAS support back in August  2016.  Not sure if they committed to fixing it.

What version of SAS are you using?

 

Hello Tom,

Thank you for bring this behavior to our attention.  I have reported it to the macro developer.

 

You can use the following syntax as a work around.

 

%put Depth =%str( )%sysmexecdepth ;

 

Regards,

---------------------------------

Kevin Russell

Foundation SAS Team

SAS Technical Support

View solution in original post


All Replies
Solution
‎10-09-2017 07:42 AM
Super User
Super User
Posts: 7,860

Re: %SYSMEXECNAME eats blanks somehow?

[ Edited ]

I raised this issue with SAS support back in August  2016.  Not sure if they committed to fixing it.

What version of SAS are you using?

 

Hello Tom,

Thank you for bring this behavior to our attention.  I have reported it to the macro developer.

 

You can use the following syntax as a work around.

 

%put Depth =%str( )%sysmexecdepth ;

 

Regards,

---------------------------------

Kevin Russell

Foundation SAS Team

SAS Technical Support

PROC Star
Posts: 1,433

Re: %SYSMEXECNAME eats blanks somehow?

Thanks Tom.  I'm running 9.4M4 on Windows.  M5 is out now, maybe somebody who has that can try it and report back.

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 2 replies
  • 99 views
  • 0 likes
  • 2 in conversation