DATA Step, Macro, Functions and more

SASUSER Library ?FOLDERID_Documents\My SAS Files\9.4 Fails on Task Scheduler

Reply
Super Contributor
Posts: 326

SASUSER Library ?FOLDERID_Documents\My SAS Files\9.4 Fails on Task Scheduler

On the default u8 sasv9.cfg there's a section on SASUSER

 

-SASUSER "?FOLDERID_Documents\My SAS Files\9.4"

 

When I execute my sas scripts manually or through command prompt, I get no issues. But when I execute the script through Windows Task Scheduler I get an error that it cannot find FOLDERID_Documents. 

 

Currently I resolved my problem in the task scheduler by remove lines which tries to reference FOLDERID_Documents

 

Is there any SAS Note what causes and explains these? What's the default behavior if I remove these on my config file?

Super Contributor
Posts: 345

Re: SASUSER Library ?FOLDERID_Documents\My SAS Files\9.4 Fails on Task Scheduler

Which user starts the job when running as task?

Super Contributor
Posts: 326

Re: SASUSER Library ?FOLDERID_Documents\My SAS Files\9.4 Fails on Task Scheduler

Posted in reply to andreas_lds

It's an admin account with privilege as Run As Batch Job

Super User
Posts: 11,343

Re: SASUSER Library ?FOLDERID_Documents\My SAS Files\9.4 Fails on Task Scheduler

Are you in a server environment?

 

You may want to create a specific config file for scheduled jobs to points to a fixed location for SAS user instead of the windows Users etc folders. Set up the command line for the scheduled job to use that configuration file with the -config option for the command line.

 

 

Super Contributor
Posts: 326

Re: SASUSER Library ?FOLDERID_Documents\My SAS Files\9.4 Fails on Task Scheduler

Yes this is what I currently my setup. But I actually copied it from the u8 folder as a baseline and then removed those options I do not need.

Ask a Question
Discussion stats
  • 4 replies
  • 124 views
  • 1 like
  • 3 in conversation