DATA Step, Macro, Functions and more

SAS PC CONNECT not work on laptop with Win7

Reply
Contributor
Posts: 73

SAS PC CONNECT not work on laptop with Win7

Hello everyone,

I've tried the same following program and it works on PC as well as on a Thinkpad with WinXP. However, on a laptop with Win7 it always stops right after I've submitted the program, saying something like "SAS stops executing the program".

%let wrds = wrds.wharton.upenn.edu 4016;
options comamid=TCP remote=WRDS;
signon username=_prompt_;
rsubmit;

/*My SAS codes here*/

endrsubmit;


My questions: Is that because of some firewall/anti-virus software on my laptop? Or it's due to the remote server I'm trying to connect to or Windows 7 on my laptop?

Anyone has a similar experience?

Thanks a lot Message was edited by: smilingmelbourne
Super User
Posts: 11,343

Re: SAS PC CONNECT not work on laptop with Win7

Posted in reply to smilingmelbourne
My first thought would be to confirm that CONNECT is licensed.

Try:

Proc setinit;run;

on the affected machine and see if Connect shows in the products.
Contributor
Posts: 73

Re: SAS PC CONNECT not work on laptop with Win7

Thanks for reply. I do have SAS Connect on the laptop. Below is what I had after submitting proc sentinit.

Expiration: 28FEB2012.
Grace Period: 15 days (ending 14MAR2012).
Warning Period: 15 days (ending 29MAR2012).
System birthday: 20MAR2011.
Operating System: W32_E .
Product expiration dates:
---Base Product 28FEB2012
---SAS/STAT 28FEB2012
---SAS/GRAPH 28FEB2012
---SAS/ETS 28FEB2012
---SAS/FSP 28FEB2012
---SAS/OR 28FEB2012
---SAS/AF 28FEB2012
---SAS/IML 28FEB2012
---SAS/QC 28FEB2012
---SAS/SHARE 28FEB2012
---SAS/CONNECT 28FEB2012---SAS/INSIGHT 28FEB2012
---SAS/EIS 28FEB2012
---SAS/SHARE*NET 28FEB2012
---SAS Enterprise Miner 28FEB2012
---SAS/IntrNet 28FEB2012
---MDDB Server common products 28FEB2012
---SAS Integration Technologies 28FEB2012
---AppDev Studio 28FEB2012
---Enterprise Miner Server 28FEB2012
---Enterprise Miner Thin Client 28FEB2012
---OR OPT 28FEB2012
---OR PRS 28FEB2012
---OR IVS 28FEB2012
---OR LSO 28FEB2012
---SAS/ACCESS Interface to ORACLE 28FEB2012
---SAS/ACCESS Interface to PC Files 28FEB2012
---SAS/ACCESS Interface to ODBC 28FEB2012
---SAS/ACCESS Interface to OLE DB 28FEB2012
---SAS Stat Studio 28FEB2012
---SAS Workspace Server for Local Access 28FEB2012
Super User
Posts: 10,023

Re: SAS PC CONNECT not work on laptop with Win7

Posted in reply to smilingmelbourne
[pre]
%let wrds = wrds.wharton.upenn.edu 4016;
options comamid=TCP remote=WRDS; <-------&WRDS ?
signon username=_prompt_;
rsubmit;

[/pre]
Contributor
Posts: 73

Re: SAS PC CONNECT not work on laptop with Win7

%let wrds = wrds.wharton.upenn.edu 4016;
options comamid=TCP remote=WRDS; <-------&WRDS ?
signon username=_prompt_;
rsubmit;



No, there should be no & in front of WRDS. Actually, those lines of codes are what they provide and are supposed to be exactly like that. Also, I used these lines in running SAS Connect on a PC and on a laptop with WinXP and it worked perfectly. So I don't think the error comes from missing & as you pointed out.

Anyway, I just began to find out how to run SAS codes in Unix via SSH Shell Client and it serves the purpose well.

Thanks a lot for your time.
Valued Guide
Posts: 2,177

Re: SAS PC CONNECT not work on laptop with Win7

Posted in reply to smilingmelbourne
> %let wrds = wrds.wharton.upenn.edu 4016;
> options comamid=TCP remote=WRDS; <-------&WRDS ?
> signon username=_prompt_;
> rsubmit;
>
> [ / p ] ..... ?
>
> No, there should be no & in front of WRDS. Actually,
> those lines of codes are what they provide and are
> supposed to be exactly like that. Also, I used these
> lines in running SAS Connect on a PC and on a laptop
> with WinXP and it worked perfectly. So I don't think
> the error comes from missing & as you pointed out.
>
> Anyway, I just began to find out how to run SAS codes
> in Unix via SSH Shell Client and it serves the
> purpose well.
>
> Thanks a lot for your time.

That & would cause the macro language handler to expand the macro variable. The signon needs a value for the remote= option that is no more than 8 characters. Rather than make it more flexible, the engineers at SAS/Connect decided to check the value for the REMOTE= against the macro variable pool assuming it will resolve to a valid ip address and port number for the SAS/Connect service (when communuactions access method (comamid) is tcp) >>> probalbly better described in the SAS/Connect manual at http://support.sas.com/documentation/cdl/en/connref/61908/HTML/default/cremote.htm
Ask a Question
Discussion stats
  • 5 replies
  • 393 views
  • 0 likes
  • 4 in conversation