DATA Step, Macro, Functions and more

Remote Sign-on on WRDS does not work, why?!

Reply
Frequent Contributor
Posts: 75

Remote Sign-on on WRDS does not work, why?!

Hi All,

I am trying to run remote sas on wrds by this code:

%let wrds = wrds.wharton.upenn.edu 4016;

options comamid = TCP remote=WRDS;

signon username=_prompt_;  /* I also tried this option: Username=XXXX Password=XXXX but got the same result*/

rsubmit;


but after I enter the user and password in the prompted window , I come to this error log:


195  %let wrds = wrds.wharton.upenn.edu 4016;

196  options comamid = TCP remote=WRDS;

197  signon username=_prompt_;

NOTE: Remote signon to WRDS commencing (SAS Release 9.02.01M0P020508).

ERROR: A communication subsystem partner link setup request failure has occurred.

ERROR: Cannot start remote process.

ERROR: Remote signon to WRDS canceled.

198

199

200

201  rsubmit;

ERROR: A link must be established by executing the SIGNON command before you can communicate

       with WRDS.

ERROR: Remote submit to WRDS canceled


Can anyone please help me why is this happening? Could it be because of my firewall settings?

Thanks


PROC Star
Posts: 7,356

Re: Remote Sign-on on WRDS does not work, why?!

I'm not familiar with WRDS, and don't know from where (or on what) you are trying to access it, but possibly the following might help:

http://www.mysmu.edu/faculty/rogerloh/database/WrdsTunnelConnection.pdf

Frequent Contributor
Posts: 75

Re: Remote Sign-on on WRDS does not work, why?!

Thanks a lot Arthur,

I should wait till my administrator installs that for me to see whether works.

User
Posts: 1

Re: Remote Sign-on on WRDS does not work, why?!

Try input your username using all small letters. Wrds support said that the username for remote access is case-sensitive.

 

Sometimes I need to restart SAS to make this step work. Before getting to this step, I also tried to deactivate my firewall/ allow the SAS to go through firewall. 

 

Hope it helps. 

Ask a Question
Discussion stats
  • 3 replies
  • 1644 views
  • 0 likes
  • 3 in conversation