DATA Step, Macro, Functions and more

Proc Reg ODS OUTPUT not working for residual output

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 8
Accepted Solution

Proc Reg ODS OUTPUT not working for residual output

Hi all,

 

I have an issue with the ODS OUTPUT when I use PROC REG. Here is the code I use:

 

proc reg data=have TABLEOUT rsquare plots=none outest=want1 edf;
m1: model y = x  /r  ADJRSQ;

ods output r=want2;
quit;

 

I get the messate:

"Output 'r' was not created. Make sure that the output object name, label, or
path is spelled correctly. Also, verify that the appropriate procedure options are used
to produce the requested output object. For example, verify that the NOPRINT option is
not used."

 

I get the same message when I use "residual" instead of "r". Is there a way to get it to work or somehow export the residuals in a dataset?

 

Thank you,

 

Nick

 


Accepted Solutions
Solution
‎05-17-2016 11:06 AM
Respected Advisor
Posts: 4,920

Re: Proc Reg ODS OUTPUT not working for residual output

Residuals are obtained with the statement

 

output out=want2 r=resid;

PG

View solution in original post


All Replies
Solution
‎05-17-2016 11:06 AM
Respected Advisor
Posts: 4,920

Re: Proc Reg ODS OUTPUT not working for residual output

Residuals are obtained with the statement

 

output out=want2 r=resid;

PG
Occasional Contributor
Posts: 8

Re: Proc Reg ODS OUTPUT not working for residual output

Thank you very much!

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 2 replies
  • 280 views
  • 1 like
  • 2 in conversation