DATA Step, Macro, Functions and more

Problem with SAS Integration Technologies 9.2

Reply
Occasional Contributor
Posts: 11

Problem with SAS Integration Technologies 9.2

Hi

After installing SAS Integration Technlogies 9.23 and launching ITConfig2.exe and entering the SAS Metadata Server details. I am getting following error:

"The object invoked has disconnected from its clients."

I suspect some problem with DCOM setting. Also, SAS is not installed locally and I am trying to connect to a remote SAS server.

Details on error is as follows:
******************************************************************************
System.Runtime.InteropServices.COMException (0x80042002):

The object invoked has disconnected from its clients.

0x80010108
******************************************************************************

Does anyobdy has any clues, why is this happening.? Any help would be appreciated.

Note: I am able to connect to Workspace server but problem comes while connecting to SAS Metadata server.

Thanks
Vinay
Super Contributor
Super Contributor
Posts: 3,174

Re: Problem with SAS Integration Technologies 9.2

Your best option is to contact SAS tech support and open a track (support issue/contact -- from the SAS.COM support website) to report your problem symptom condition for assistance and guidance.

Scott Barry
SBBWorks, Inc.
SAS Employee
Posts: 224

Re: Problem with SAS Integration Technologies 9.2

Hi Vinay,
You may get great suggestions from the group here; however, you may also want to submit your question to SAS Technical Support. There is a form here that you can use: http://support.sas.com/openTrack

Good luck.
Occasional Contributor
Posts: 11

Re: Problem with SAS Integration Technologies 9.2

Hi All

Had raised it with SAS but could get this resolved. Lately I noticed that ITCONFIG2.EXE does connects successfully to SAS 9.2/9.3 Metadata Server while gives issues with SAS 9.1.3 server.

i could not exactly pin point the issues but I suspect with SAS 9.2/9.3 , SAS has changed the SAS Metadata Server COM Class identifier as such ITCONFIG2.exe fails to connect to SAS 9.1.3 SAS Metadata server.

I confirmed this by trying to connect to SAS 9.1.3 server using SAS EG 5.1 and it does fail to connect to SAS 9.1.3.

Thanks

Vinay

Ask a Question
Discussion stats
  • 3 replies
  • 368 views
  • 0 likes
  • 3 in conversation