DATA Step, Macro, Functions and more

Libref assigned but does not appear

Reply
Occasional Contributor t30
Occasional Contributor
Posts: 14

Libref assigned but does not appear

Hi,

 

Librefs are successfully assigned, but don't appear in the library section

 

librerf.PNG

Super User
Posts: 3,261

Re: Libref assigned but does not appear

Did you press the Library Refresh button after assigning them?

Occasional Contributor t30
Occasional Contributor
Posts: 14

Re: Libref assigned but does not appear

Yeah, I clicked on the refresh button, though nothing happens
Super User
Posts: 19,878

Re: Libref assigned but does not appear

What happens if you run a proc datasets on tht library?

 

proc datasets lib=odsprinm (sp?);

run;quit;

Trusted Advisor
Posts: 1,586

Re: Libref assigned but does not appear

After refreshing click on "Server Files and Folders" and then back to "My Libraries".

Occasional Contributor t30
Occasional Contributor
Posts: 14

Re: Libref assigned but does not appear

I refreshed on both, still the same here. I also tried logging out and signing in and redo, but still the same.
Occasional Contributor t30
Occasional Contributor
Posts: 14

Re: Libref assigned but does not appear

Seems like it does show the datasets available if I submit proc datasets.

 

 

appear.PNG

Super User
Posts: 3,261

Re: Libref assigned but does not appear

What versions of SAS Studio and SAS are you using? Maybe it is something to do with this:

 

http://support.sas.com/kb/57/814.html

Occasional Contributor t30
Occasional Contributor
Posts: 14

Re: Libref assigned but does not appear

Not sure how do I check for SAS Studio version

 

From proc setinit; this is the SAS version

Current version: 9.04.01M3P062415

Super Contributor
Posts: 441

Re: Libref assigned but does not appear

I suspect it's related to this issue http://support.sas.com/kb/57/814.html

Ask a Question
Discussion stats
  • 9 replies
  • 95 views
  • 2 likes
  • 5 in conversation