DATA Step, Macro, Functions and more

LINESIZE=MAX for local submit and remote submit -- Not getting correct display

Reply
New Contributor
Posts: 2

LINESIZE=MAX for local submit and remote submit -- Not getting correct display

Hi,

When I ran the SAS code with option LINESIZE=MAX, the log window print the details correctly, but in the remote submit using SIGNON the log window details not getting correctly for the LINESIZE=MAX option.

The local submit log printed in single line and remote submit log printed in multiple line.

Herewith I have attached the code and log details. I need to get the same displays in the log window with SIGNON and without SIGNON. What options to be used in SAS? Could any one help me to resolve this.

SAS Version: 9.2 in x64 Edition

--SAS Code---

424 option linesize=max;

425 %put sgjdslkgjdlkfgjkldfjglkdfjgfdkgjdfkljgfdklgjfdgjdklfjgdsdkgjdfskgjfldkgjdlkfgjlfdkgjdfkjgkldfjsgjdslkgjdlkfgjkldfjglkdfjgfdkgjdfkljgfdklgjfdgjdklfjgdsdkgjdfskgjfldkgjdlkfgjlfdkgjdfkjgkldfj;

sgjdslkgjdlkfgjkldfjglkdfjgfdkgjdfkljgfdklgjfdgjdklfjgdsdkgjdfskgjfldkgjdlkfgjlfdkgjdfkjgkldfjsgjdslkgjdlkfgjkldfjglkdfjgfdkgjdfkljgfdklgjfdgjdklfjgdsdkgjdfskgjfldkgjdlkfgjlfdkgjdfkjgkldfj

426 rsubmit;

NOTE: Remote submit to MYNODE commencing.

3 option linesize=max;

4 %put

sgjdslkgjdlkfgjkldfjglkdfjgfdkgjdfkljgfdklgjfdgjdklfjgdsdkgjdfskgjfldkgjdlkfgjlfdkgjdfkjgkldfjsgjdsl

kgjdlkfgjkldfjglkdfjgfdkgjdfkljgfdklgjfdgjdklfjgdsdkgjdfskgjfldkgjdlkfgjlfdkgjdfkjgkldfj;

sgjdslkgjdlkfgjkldfjglkdfjgfdkgjdfkljgfdklgjfdgjdklfjgdsdkgjdfskgjfldkgjdlkfgjlfdkgjdfkjgkldfjsgjdsl

kgjdlkfgjkldfjglkdfjgfdkgjdfkljgfdklgjfdgjdklfjgdsdkgjdfskgjfldkgjdlkfgjlfdkgjdfkjgkldfj

NOTE: Remote submit to MYNODE complete.

  zqjlinesize.PNG

Thank you,

With Best Regards

Edwin

Valued Guide
Posts: 2,174

LINESIZE=MAX for local submit and remote submit -- Not getting correct display

you might have to rsubmit the linesize=max, too

New Contributor
Posts: 2

LINESIZE=MAX for local submit and remote submit -- Not getting correct display

Thanks for the reply, I used rsubmit; option linesize=max; but no effect, I got the answer from SAS Support, we need to provide the linesize=max before signon.

"Solution from SAS Support:

The remote server session saves the linesize option of the client session at the moment of SIGNON. For the output sended back to the client the remote servers session uses this linesize option.

Changing the linesize option of the client session just before the signon will solve this problem."

Thank You,

With Best Regards

Edwin

Ask a Question
Discussion stats
  • 2 replies
  • 183 views
  • 3 likes
  • 2 in conversation