DATA Step, Macro, Functions and more

LIBNAME ERROR when Exporting to SharePoint

Accepted Solution Solved
Reply
New Contributor
Posts: 3
Accepted Solution

LIBNAME ERROR when Exporting to SharePoint

[ Edited ]

The issue that I am having is that the Export function does not work.  It did all the way till this Sunday and then just stopped.

 

I have not changed anything, and when I checked our scheduler that runs these programs, it started to error out.

 

Any help is greatly appreciated.

 

 

393 PROC EXPORT DATA = WORK.DATA_WITH_TRANSIT
394 OUTFILE = '\\mishare.corp.xxxxxx.com\DavWWWRoot\sites\xxxxxx\Grains Tracking
394! Tools\DATA_WITH_TRANSIT.xls'
395 DBMS = EXCEL REPLACE;
396 SHEET = "KMDT Data";
397 RUN;

ERROR: Connect: Failure creating file.
ERROR: Error in the LIBNAME statement.
Connection Failed. See log for details.
NOTE: The SAS System stopped processing this step because of errors.
NOTE: PROCEDURE EXPORT used (Total process time):
real time 0.12 seconds
cpu time 0.06 seconds

 

PROC EXPORT DATA = WORK.DATA_WITH_TRANSIT
OUTFILE = '\\mishare.corp.xxxxxx.com\DavWWWRoot\sites\xxxxxxxxt\Grains Tracking Tools\DATA_WITH_TRANSIT.xls'
DBMS = EXCEL REPLACE;
SHEET = "KMDT Data";
RUN;

 

 

 


Accepted Solutions
Solution
‎09-11-2017 09:18 AM
New Contributor
Posts: 3

Re: LIBNAME ERROR when Exporting to SharePoint

Thank you, it was just that.  Somehow an _ was missing from the Sheet name KMDT Data.  It should have been KMDT_Data.

 

Thank you again!

View solution in original post


All Replies
New Contributor
Posts: 3

Re: LIBNAME ERROR when Exporting to SharePoint

[ Edited ]

This is the error, the other one I posted was me just trying something and is not the correct error:

 

 

398 PROC EXPORT DATA = WORK.DATA_WITH_TRANSIT
399 OUTFILE = '\\mishare.corp.xxxxxxxx\DavWWWRoot\sites\xxxxxxxx\Grains Tracking
399! Tools\DATA_WITH_TRANSIT.xls'
400 DBMS = EXCEL REPLACE;
401 SHEET = "KMDT Data";
402 RUN;

ERROR: Connect: Failure creating file.
ERROR: Error in the LIBNAME statement.
Connection Failed. See log for details.
NOTE: The SAS System stopped processing this step because of errors.
NOTE: PROCEDURE EXPORT used (Total process time):
real time 0.09 seconds
cpu time 0.04 seconds

 

Super User
Posts: 13,542

Re: LIBNAME ERROR when Exporting to SharePoint

You might share the libname statement. You might have something missing like a ) or ; on the libname such that the error doesn't appear until the middle of other code.

Solution
‎09-11-2017 09:18 AM
New Contributor
Posts: 3

Re: LIBNAME ERROR when Exporting to SharePoint

Thank you, it was just that.  Somehow an _ was missing from the Sheet name KMDT Data.  It should have been KMDT_Data.

 

Thank you again!

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 3 replies
  • 273 views
  • 0 likes
  • 2 in conversation