DATA Step, Macro, Functions and more

Issue while publishing formats in Teradata

Reply
New Contributor
Posts: 2

Issue while publishing formats in Teradata

Below is the following details of the server:

 

SAS version: 9.4

Server:RHEL 6.6(SANTIAGO)

 

While trying to publish formats in teradata from pc-sas(Linux GUI), the script is running fine.However, when trying to publish formats in teradata from pc-sas (windows), it is throwing following warning:

 

destination buffer error.png

 

Attached the script for your refference

 

*Note: The td_login_new.sas program setup the credentials for accessing the sas server and setting up the required libraries.

 

What is the root cause and solution for this?

          

Attachment
Regular Contributor
Posts: 212

Re: Issue while publishing formats in Teradata

Posted in reply to Swetank_Nandi

Hi mate,

 

I found something that says, this problem is most likely to occur if any of the path options, such as DATAPATH= or INDEXPATH=, contain double-byte character set (DBCS) characters.

 

Chek out SAS® Scalable Performance Data

 

Att

New Contributor
Posts: 2

Re: Issue while publishing formats in Teradata

Posted in reply to DartibaliRodrigo

I have already go through this explanation, however, it is not working

Trusted Advisor
Posts: 3,215

Re: Issue while publishing formats in Teradata

Posted in reply to Swetank_Nandi

There is somthing weird wiht the encoding. It looks the default settings are Unicode16 (Teradata) and a latin1 (your sas session)
When getting Formats into TD  that was mentioned wiht 9.2 as a limitation at up no notes anymore about those anymore. Still strange that conversion there.  

---->-- ja karman --<-----
Ask a Question
Discussion stats
  • 3 replies
  • 228 views
  • 0 likes
  • 3 in conversation