DATA Step, Macro, Functions and more

Importing text file in university edition

Reply
Regular Learner
Posts: 1

Importing text file in university edition

[ Edited ]

 

 

1 OPTIONS NONOTES NOSTIMER NOSOURCE NOSYNTAXCHECK; 
55 
56 libname project "/folders/myfolders" ; 
NOTE: Libref PROJECT was successfully assigned as follows: Engine: V9 Physical Name: /folders/myfolders 
57 
58 
59 
60 proc import datafile= "/folders/myfolders/b.txt” 
61 OUT=WORK.MYEXCEL; 
62 DBMS=TEXT 
63 REPLACE; 
64 RUN; 
65 
66 
67 
68 
69 
70 
71 
72 
73 
74 OPTIONS NONOTES NOSTIMER NOSOURCE NOSYNTAXCHECK; 
75 ODS HTML CLOSE; 
76 &GRAPHTERM; ;*';*"; 
ERROR: Output SAS data set must be provided. 
NOTE: The SAS System stopped processing this step because of errors. NOTE: PROCEDURE IMPORT used (Total process time): real time 0.00 seconds cpu time 0.00 seconds 76 ! */;RUN;QUIT; 
77 QUIT;RUN; 
78 ODS HTML5 (ID=WEB) CLOSE; 
79 
80 ODS RTF (ID=WEB) CLOSE; 
81 ODS PDF (ID=WEB) CLOSE; 
NOTE: ODS PDF(WEB) printed no output. (This sometimes results from failing to place a RUN statement before the ODS PDF(WEB) CLOSE statement.) 
82 FILENAME _GSFNAME; 
NOTE: Fileref _GSFNAME has been deassigned. 83 DATA _NULL_; 
84 RUN; 
NOTE: DATA statement used (Total process time): real time 0.00 seconds cpu time 0.01 seconds 
85 OPTIONS NOTES STIMER SOURCE SYNTAXCHECK; 
86
Super Contributor
Posts: 408

Re: Importing text file in university edition

Maybe you have a question? usually you get the best answers by asking a clear question and providing all info involved (not just the log that doesn't even show your code).

 

- Jan.

Super User
Posts: 10,483

Re: Importing text file in university edition

[ Edited ]

As a minimum it looks like the file name for your data file is incorrect as pasted. It appears that your file name ends in quotes but when I paste your log entry into the editor I get a character that translates to something else (in my case something that looks likea double line character. If you look in your post in this forum you will see curly closing quotes instead of straight " quotes.

 

So try retyping your datafile name completely.  This kind of thing sometimes happens when copying text from other applications/ web pages and the characters have been changed from the basica ASCII characters the editor uses.

 

 

Super User
Posts: 17,784

Re: Importing text file in university edition

You have an extra semicolon, that's too early and it does look like your quotes are incorrect.

I don't know if DBMS=TEXT is valid either, you need to determine what the delimiter of your file is, for example TAB or CSV. 

 

proc import datafile= "/folders/myfolders/b.txt"
OUT=WORK.MYEXCEL 
DBMS=TAB 
REPLACE; 
RUN; 
Ask a Question
Discussion stats
  • 3 replies
  • 197 views
  • 0 likes
  • 4 in conversation