DATA Step, Macro, Functions and more

How can I supress this message in the log

Reply
N/A
Posts: 0

How can I supress this message in the log

My log is filled with iterations of this message identifying SAS Files in Libs I have allocated.

NOTE: Data file xxxxx.zzzzz is in a format that is native to another host, or the file encoding does not match the session encoding. Cross Environment Data Access will be used, which might require additional CPU resources and might reduce performance.

1) What causes this mesasge to be displayed?
Most of the time the message references a file that I created from a SAS transport file, but not always. I thought SAS Transport files addressed the cross-environment

2) Is there any way to suppress it?
I changed my msglevel from 'N' to 'I', but the messages are still displayed (although they are in black instead of blue like the other messages).

I'm using Windows 9.2

This message dramatically increases the size of my log file (which I need to keep) and makes it very difficult to detect a real problem.


I'd appreciate any suggestions that woudl help me.
Contributor
Posts: 74

Re: How can I supress this message in the log

it could be that your source data xxxx.zzzzz is created or transferred from a unix server.
one way to supress this particular message is to flank the part of code that generates the message with options nonotes; and options notes;
very likely it is the data step referring to this data set.
PROC Star
Posts: 1,566

Re: How can I supress this message in the log

Have you read the CEDA pages?
Particularly:http://support.sas.com/documentation/cdl/en/lrcon/61722/HTML/default/a002143983.htm

Also about data migration:
http://support.sas.com/rnd/migration/planning/files/crossplatform.html


Why CEDA Is Invoked for a SAS®9 File in a SAS®9 Session
Character encoding: CEDA is invoked when you share a file with users in another locale who have an incompatible encoding. For more information, see the topic about national language support or see Processing Data Using Cross-Environment Data Access (CEDA) in SAS Language Reference: Concepts.

Operating environment family: In a SAS®9 session, you can run the CONTENTS procedure on any SAS®9 file to determine the operating environment where it was created. To learn the operating environment of your current SAS®9 session, create a quick data set and run PROC CONTENTS on it. If the data representation of the file matches that of your current operating environment, then the file is native on that operating environment. If you're running under AIX, Solaris, or HP-UX, you'll notice all of those operating environments are listed in the log, because those operating environments comprise an operating environment family.




To know when CEDA is being used, set the SAS system option MSGLEVEL=I. That is:

options msglevel=i;
Here's an example of the message that displays in the log:

INFO: Data file MYFILES.GRADES.DATA is in a format that is native to
another host, or the file encoding does not match the session encoding.
Cross Environment Data Access will be used, which might require
additional CPU resources and might reduce performance.
Beginning with SAS 9.1.3 Service Pack 4, you get this behavior even if you do not specify MSGLEVEL=I.


Run proc contents, and use the OUTREP= option if needed.
Respected Advisor
Posts: 3,777

Re: How can I supress this message in the log

[pre]
options generic;
[/pre]

update.

While this option does suppress the CEDA message it also effects how messages are displayed in LIBNAME and FILENAME statements which also effects the text returned by the PATHNAME function. This could be undesirable.

[pre]
options generic=0;
libname here '.';
libname here list;
%put NOTE: %sysfunc(pathname(here,L));


options generic=1;
%put NOTE: %sysfunc(pathname(here,L));
libname here list;

options generic=0;
%put NOTE: %sysfunc(pathname(here,L));
libname here list;
[/pre] GENERIC option effects more than CEDA message.


Message was edited by: data _null_;
Ask a Question
Discussion stats
  • 3 replies
  • 499 views
  • 0 likes
  • 4 in conversation