DATA Step, Macro, Functions and more

Encoding Error when using WRDS

Reply
New Contributor
Posts: 2

Encoding Error when using WRDS

Hello all,

 

Actually, I am a beginner using SAS. I face an error/warning when I want to download some data from WRDS (Wharton Research Data Services). 

 

This is the error that I get:

 

"WARNING: The client session encoding shift-jis is not compatible with the server session encoding latin1. Data may not be transmitted correctly."

 

I tried to change SAS session encoding but it was not successful. 

 

Is there anyone here who knows how should I deal with this problem?

 

 

 

Here is the simplest version of the code that I use:

 

*****************************************************************************************************************

libname Mycrsp "C:\Users\H\Documents\My SAS Files\9.4\WRDS";

 

%let wrds = wrds.wharton.upenn.edu 4016; options comamid = TCP remote=WRDS;
signon username=_prompt_;

 

rsubmit;
libname WRDScrsp '/wrds/crsp/sasdata';
PROC SQL;
create table k as
select PRC
from WRDScrsp.dsf
where permno='14593';
quit;


proc download data=k out=Mycrsp.dsf;run;
endrsubmit;

*****************************************************************************************************************

 

Best,

PROC Star
Posts: 2,369

Re: Encoding Error when using WRDS

It seems like your SAS session uses Japanese encoding. 

Try starting it with encoding wlatin1 .

See here http://support.sas.com/documentation/cdl/en/nlsref/61893/HTML/default/viewer.htm

New Contributor
Posts: 2

Re: Encoding Error when using WRDS

I tried to change encoding by editing "sasv9.cfg" file but I cannot save it. An error appears telling that I need a permission to make any changes.

Ask a Question
Discussion stats
  • 2 replies
  • 107 views
  • 0 likes
  • 2 in conversation