DATA Step, Macro, Functions and more

Email going to Outlook outbox

Reply
Regular Contributor
Posts: 171

Email going to Outlook outbox

When attempting to send an email via a SAS data step, we have one computer where the email message is sent to the user's Outlook 07 outbox instead of being immediately distributed to the intended recipients. When the program is executed on any of our other computers, the email message is sent immediately. Has anyone else encountered this issue? Is there some property that can be set in Outlook to control this behavior?

Thanks in advance for your assistance.
PROC Star
Posts: 7,468

Re: Email going to Outlook outbox

Have you checked, in Outlook (probably under tools->send/receive->send/receive settings) how often their Outlook is scheduled to automatically send and receive?

Art
Super Contributor
Posts: 356

Re: Email going to Outlook outbox

What is your code to send and your SAS email settings, as this will help to resolve for you
Trusted Advisor
Posts: 2,115

Re: Email going to Outlook outbox

This is not an answer to your question, but an alternate solution. If you send the e-mail directly through your SMTP gateway you get the user's e-mail client out of the picture altogether.
Regular Contributor
Posts: 171

Re: Email going to Outlook outbox

Many thanks to everyone who replied. Please forgive the lateness of my response.

@ Art: The Outlook automatic send/receive settings are not activated on the computer. I attempted changing this setting but it did not fix the problem.

@twocanbazza: Here are the SAS email settings.
Emailauthprotocol – None
Emailfrom-0
Emailhost - LOCALHOST
Emailid-
Emailport-25
Emaildlg - NATIVE
Emailsys – MAPI

The code used to send the email is very generic. Here is an outline of the code.

FILENAME MAIL EMAIL ‘ ’
TO=(‘email address’)
SUBJECT=’ subject of email’
ATTACH=(‘location of an attached CSV file’);
DATA _NULL_;
FILE MAIL;
PUT “some text contained in the body of the email”;
RUN;

@Doc: Thanks for the great suggestion. Unfortunately, my site will not allow me to use SMTP due to the requirement of setting the EMAILPW option.

Any other suggestions would be greatly appreciated. Thanks again.
Ask a Question
Discussion stats
  • 4 replies
  • 198 views
  • 0 likes
  • 4 in conversation