DATA Step, Macro, Functions and more

EXCEL LIBNAME option and DBMAX_TEXT not working as expected

Reply
Contributor
Posts: 54

EXCEL LIBNAME option and DBMAX_TEXT not working as expected

Hi,

 

I am trying to read in an Excel workbook using the LIBNAME statement with the EXCEL option. This normally works just fine but one of the columns in my workbook contain data >1024 in length. So I used the DBMAX_TEXT option to increase the available size of the data imported and when I run a PROC CONTENTS the variable (Body) shows up as a Character of length 5494.

 

However when I try to use this dataset (proc print or via a data step) I get the warning in the log: 

WARNING: During read: Data truncated for column Body

 

Has anyone else managed to successfully use this option?

 

I'm running SAS v9.4 TS4 on a Grid using EG (and Studio) to run programs.

 

Cheers,

Lawrence

Super User
Posts: 9,593

Re: EXCEL LIBNAME option and DBMAX_TEXT not working as expected

[ Edited ]
Posted in reply to LawrenceHW

Save to a csv file and use proc import once with guessingrows=max to determine the needed size for the column. Then use the resulting data step for future imports.

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
How to convert datasets to data steps
How to post code
Super User
Super User
Posts: 7,857

Re: EXCEL LIBNAME option and DBMAX_TEXT not working as expected

Posted in reply to LawrenceHW

Did you try using the XLSX engine instead of EXCEL engine?

Ask a Question
Discussion stats
  • 2 replies
  • 101 views
  • 0 likes
  • 3 in conversation