DATA Step, Macro, Functions and more

Disable SAS pop-up

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 13
Accepted Solution

Disable SAS pop-up

How do you disable this SAS pop-up? Have clicked on the 'Don't show this dialog box again' but it still re-appears every time I start up a SAS session. Please advice.

sas_popup.JPG

 


Accepted Solutions
Solution
‎10-12-2017 07:27 PM
Occasional Contributor
Posts: 13

Re: Disable SAS pop-up

I got a reply from SAS regarding this and it solved my problem.

 

I added the -NOTUTORIALDLG in my sas config file.

View solution in original post


All Replies
Super User
Posts: 3,256

Re: Disable SAS pop-up

I suspect this behaviour is due to your SASUSER library being set to read-only so customisations can't be saved.

 

To confirm if this is the case run: PROC OPTIONS and check if the RSASUSER option is set.

Occasional Contributor
Posts: 13

Re: Disable SAS pop-up

I ran the proc options as suggested. and I get this result in regards to SASUSER :-

NORSASUSER Opens the Sasuser library in Write mode.

 

 

Super User
Posts: 19,822

Re: Disable SAS pop-up

Look at the message in the log, right behind your pop up. When you make this change make sure it's in the only SAS instance running so the options can be saved. 

Frequent Contributor
Posts: 100

Re: Disable SAS pop-up

The option to disable may have been applied to your original (first sas session).  Any new session, sas will revert to default.  And log says something about your settings too.

Occasional Contributor
Posts: 13

Re: Disable SAS pop-up

Posted in reply to ShiroAmada

I probably should have updated in detail how I get this pop-up screen. This screen is disabled in my initial screen when I start SAS for the first time but when another SAS session is triggered ( e.g. when a local SAS ODBC connection is invoked), then I get this pop-up screen on my second SAS session.

Occasional Contributor
Posts: 13

Re: Disable SAS pop-up

Is there a sas option that I could use?

Super User
Posts: 3,256

Re: Disable SAS pop-up

This is a "feature" of opening a second SAS Windowing Environment session. Your first session has locked the SASUSER.PROFILE catalog where your preference is stored, so the second session is unable to open it.

 

If you started BOTH of your sessions with the -RSASUSER option I think it will disable the pop-up. You could test this from the Windows Run box by running SAS -RSASUSER twice. 

Occasional Contributor
Posts: 13

Re: Disable SAS pop-up

I used that option on my startup sas but it did not work. My code starts up a separate SAS session for an ODBC connection as it's refreshing a pivot table from a SAS table and that SAS session still has the pop-up.

If I run multiple SAS sessions on my PC, it does not show the pop-up for each session.

Super User
Posts: 3,256

Re: Disable SAS pop-up

In that case you haven't fully explained how you are starting your problematic SAS session and what it is doing. Please provide these details.

Super User
Posts: 7,809

Re: Disable SAS pop-up

- Start a SAS session with norsasuser

- disable the popup

- close the SAS session

- change the option in the configuration to rsasuser

 

After that, all concurrent SAS sessions should have read access to your sasuser.profile and respect the setting.

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
Occasional Contributor
Posts: 13

Re: Disable SAS pop-up

Posted in reply to KurtBremser

Hi Kurt,

 

I tried your suggestion but it still shows the pop-up screen only when the main sas session triggers another SAS screen e.g. the ODBC connect session.

 

Solution
‎10-12-2017 07:27 PM
Occasional Contributor
Posts: 13

Re: Disable SAS pop-up

I got a reply from SAS regarding this and it solved my problem.

 

I added the -NOTUTORIALDLG in my sas config file.

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 12 replies
  • 281 views
  • 6 likes
  • 5 in conversation