Architecting, installing and maintaining your SAS environment

total jvm memory < 14.3MB in Environment Manager

Accepted Solution Solved
Reply
Contributor
Posts: 38
Accepted Solution

total jvm memory < 14.3MB in Environment Manager

Hi, all.

 

I am encountering a problem that the environment manager always give out an alert message (HQ Agent Memory - JVM Free Memory < 14.3 MB (actual value = 10.6 MB))

 

I know what it is meaning and I would like to know how to tackle it so that it won't appear anymore.

 

1. I dont't want to edit/increase 14.3 in the definition part.

2. I have edited "SAS-configuration-directory/Levn/Web/WebAppServer/SASServer1_n/bin/setenv.sh" with new parameters : Xmx8192m -Xss256k -Xmso256k -Xms4096m -XXSmiley TongueermSize:512m -XX:MaxPermSize:512m, but it seems no different.

 

Thanks for any help


Accepted Solutions
Solution
‎05-09-2017 09:47 PM
Contributor
Posts: 38

Re: total jvm memory < 14.3MB in Environment Manager

[ Edited ]

It is the correct file, but only changing the "wrapper.java.additional.2=-Xmx128m" cannot deal with the problem properly.

 

Also, you need to edit the "Initial Java Heap Size" which is initially commented and and the "Maximun Java Heap Size" too.\

 

For my setting, I have changed:

1. wrapper.java.additional.2=-Xmx1024m

2. wrapper.java.initmemory=512

3. wrapper.java.maxmemory=1024

View solution in original post


All Replies
Contributor
Posts: 55

Re: total jvm memory < 14.3MB in Environment Manager

[ Edited ]

You said the message was for: (HQ Agent Memory - JVM Free Memory < 14.3 MB).

 

You changed the setting for SASServer 1, which doesn't help the agent.

 

1. Stop the agent (Even if it is not running just to be sure)

----------------------------

cd /<SASCONFIG>/Lev1/Web/SASEnvironmentManager/agent-5.0.0-EE/bin

./hq-agent.sh stop

 

2. Edit wrapper.conf

----------------------------

cd /<SASCONFIG>/Lev1/Web/SASEnvironmentManager/agent-5.0.0-EE/bundles/agent-5.0.0/conf

Edit wrapper.conf:

Look at entry  "wrapper.java.additional.2="

Default is "wrapper.java.additional.2=-Xmx128m"

Test with  -Xmx512m,

 

 

 

3. Restart agent:

----------------------------

cd /<SASCONFIG>/Lev1/Web/SASEnvironmentManager/agent-5.0.0-EE/bin

./hq-agent.sh start

Solution
‎05-09-2017 09:47 PM
Contributor
Posts: 38

Re: total jvm memory < 14.3MB in Environment Manager

[ Edited ]

It is the correct file, but only changing the "wrapper.java.additional.2=-Xmx128m" cannot deal with the problem properly.

 

Also, you need to edit the "Initial Java Heap Size" which is initially commented and and the "Maximun Java Heap Size" too.\

 

For my setting, I have changed:

1. wrapper.java.additional.2=-Xmx1024m

2. wrapper.java.initmemory=512

3. wrapper.java.maxmemory=1024

Contributor
Posts: 55

Re: total jvm memory < 14.3MB in Environment Manager

@R_Chung - Thanks for correcting me. I looked at my wrapper.conf file and noticed that I also had changed:

 

# Initial Java Heap Size (in MB)
wrapper.java.initmemory=256

# Maximum Java Heap Size (in MB)
wrapper.java.maxmemory=512

 

and received no more alerts.

 

 

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 3 replies
  • 194 views
  • 9 likes
  • 2 in conversation