Architecting, installing and maintaining your SAS environment

sashpcmc is stopped, won't start

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 18
Accepted Solution

sashpcmc is stopped, won't start

I am standing up a new 9.4 distributed environment on RHEL7 for VA 7.3.  I'm walking through the SAS High-Performance Analytics Infrastructure 3.1 Installation and Configuration Guide. I did the pre-install work for the SAS High-Performance Computing Management Console, and also walked through the installation and configuration steps. 

 

I can see the sashpcmc service is installed, but when I execute

 

sudo service sashpcmc start
service --status-all

I get 

sashpcmc is stopped

The /var/log/messages file doesn't report a failure. Where can I see more error info? What might be preventing this from running?

 

 

 


Accepted Solutions
Solution
‎08-10-2016 01:13 PM
Occasional Contributor
Posts: 18

Re: sashpcmc is stopped, won't start

Linux apparently vexes me...

sudo service --status-all

shows

sashpcmc (pid 4072) is running

So apparently it is running, it just won't tell me unless I sudo it.

View solution in original post


All Replies
Solution
‎08-10-2016 01:13 PM
Occasional Contributor
Posts: 18

Re: sashpcmc is stopped, won't start

Linux apparently vexes me...

sudo service --status-all

shows

sashpcmc (pid 4072) is running

So apparently it is running, it just won't tell me unless I sudo it.

Occasional Contributor
Posts: 17

Re: sashpcmc is stopped, won't start

I get something like this too. When I start my metadata servers using ./sas.servers start, it says metadata server failed to start. Then I check again right after and I see it's running.  I don't know if it's a timing issue. Anyway, I'm a new admin trying to install and config this thing. 

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 2 replies
  • 310 views
  • 0 likes
  • 2 in conversation