Architecting, installing and maintaining your SAS environment

sas configuration process Error

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 8
Accepted Solution

sas configuration process Error

I am trying to configuration sas by running sas deployment wizard and i get this error can any one help ? 

 

kindly find the attached Error pics .


error.pngerror.png

Accepted Solutions
Solution
‎02-04-2016 09:57 AM
Occasional Contributor
Posts: 8

Re: sas configuration process Error

Dear all

First of all thank you very much for your time and support Smiley Happy 

the error is solved and this is the steps

1- Run this script file "generate_boot_scripts.sh"

2- This file will generate "sas.server"

3- Check the the up servers by write this command "sas.servers -status"

4-Restart servers by write this command "sas.servers -restart"

5- The error will be solved 

View solution in original post


All Replies
Regular Contributor
Posts: 170

Re: sas configuration process Error

Unfortunately there could be any number of reasons, but without seeing the full log and knowing more about your environment it's hard to tell. Can you provide the detailed error message from the logs?

You'll likely need to get SAS Tech Support involved in this one. i have seen errors on this step before and had to start the configuration phase over, but I don't recall the cause. Sorry for not being much help Smiley Sad
Occasional Contributor
Posts: 8

Re: sas configuration process Error

This the log Error file and our enviroment is redhat 6.4 and thank you

Regular Contributor
Posts: 170

Re: sas configuration process Error

Haveyoh configured any kind of SSL? Is your WIP Database server running on your app tier (SASAPP)?
Regular Contributor
Posts: 170

Re: sas configuration process Error

Have you configured SSL? Is your WIP Database server running?
Occasional Contributor
Posts: 8

Re: sas configuration process Error

no id did not  configure SSL

how can i check is the WIP Database server is running or not ? 

Regular Contributor
Posts: 170

Re: sas configuration process Error

WIP database server runs on you application/compute tier. You'll want to run "sas.servers status" in the main config directory. so for Linux it should be <CONFIG>/Lev1/sas.servers.

Run that script with "status" option and it should tell you status of all services on your app/compute tier. If WIP Database server IS running, then maybe check that you can communicate with it over the port (default is 9432) from the mid tier machine (maybe a simple telnet)
Occasional Contributor
Posts: 8

Re: sas configuration process Error

"sas.servers" i dont have this file..  maybe becouse i am still in configuration step and it is not complete Smiley Sad 

Regular Contributor
Posts: 170

Re: sas configuration process Error

Do you have a multi-machine environment? I.e. Metadata server, app/compute server, midtier/web application server?

This looks like you have multi-tier environment and you're now configuring the middle/web application tier. The WIP database wouldn't be on this server typically, but it can depend on your configuration.
Frequent Contributor
Posts: 96

Re: sas configuration process Error

Hi,

 

If you can not find sas.servers script then run generate_boot_scripts.sh script in that same directory, this script will create sas.servers and then you can check server status

Occasional Contributor
Posts: 8

Re: sas configuration process Error

server is one tier and here is the status of sas.servers

SAS servers status:
SAS Web Infrastructure Data Server is UP
SAS Data Remediation Data Server is UP
SAS Job Monitor Data Server is NOT up
SAS Metadata Server 1 is UP
SAS Object Spawner 1 is UP
SAS CONNECT Spawner 1 is UP
SAS DIP Job Runner 1 is NOT up
SAS Information Retrieval Studio Server is UP
SAS JMS Broker is UP
SAS Cache Locator Service ins_41415 is NOT up
SAS Web Server is UP
SAS Web App Server SASServer1_1 is UP
SAS Web App Server SASServer12_1 is UP
SAS Web App Server SASServer13_1 is UP
SAS Web App Server SASServer2_1 is UP
SAS Web App Server SASServer7_1 is UP
SAS Web App Server SASServer8_1 is UP
SAS Environment Manager is UP
SAS Environment Manager Agent is UP

 

Regular Contributor
Posts: 170

Re: sas configuration process Error

That's true, but may not be necessary if the app tier is already configured on another machine. I would want to check the app tier first. Just my preference though
Occasional Contributor
Posts: 8

Re: sas configuration process Error

our server is one tier we have the app and web on the same server
Frequent Contributor
Posts: 96

Re: sas configuration process Error

As per my talk with SAS Folks,

Load content just load some sample datas, It will not configure in SAS Environment,
So if you have no need of sample datas of SAS, then you can go ahead by clicking yes, Same error is faced in CentOS 7, and after click on YES, when installtion is completed, SAS gave no error in its environment.

Regular Contributor
Posts: 170

Re: sas configuration process Error

True, but it's nice to have an installation/configuration that has no errors in it, that way if you encounter problems later you can rule out a faulty installation/configuration and don't have to worry about doing it all over again.  Smiley Happy

 

Have you tried selecting "Retry" to see if can load the content again?  I've seen it happen where there was just a communications error and it worked after retrying (but usually there is something else going on that would prevent it from properly loading sample content).

 

 

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 17 replies
  • 1055 views
  • 7 likes
  • 3 in conversation