Architecting, installing and maintaining your SAS environment

remote browsing

Accepted Solution Solved
Reply
New Contributor
Posts: 4
Accepted Solution

remote browsing

Hello everyone.

I'd like to know if (and where) a documentation exists that explains what is exactly the remote browsing agent, how it is installed and configured, or even disabled in order to get back to classical internal display.

I have successfully installed SAS 9.3 (Linux), but trying to view the help or graphical output results in an error explaining that the server is unreachable. From what I understand after some googling, the problem is that I don't have an agent running on the system. Why is it not installed when SAS is? I have tried to copy it (ie: the file rbrowser) in /usr/local/bin/ and start it manually, but SAS apparently still doesn't find it because the system is not registered in any DNS server. I have already tried using various command lines to start SAS, like:

/usr/local/SAS/sas_9.3/SASFoundation/9.3/sas -helphost localhost

or

/usr/local/SAS/sas_9.3/SASFoundation/9.3/sas -helphost 127.0.0.1

Without improvement.

I suspect I've missed a couple of important things, but I feel rather lost.

Any help would be apprecciated because I'm starting to bang my head against the walls... :smileycry:


Accepted Solutions
Solution
‎11-02-2011 05:44 AM
New Contributor
Posts: 4

remote browsing

Thanks for your answers, they may come in very handy, particularly the workaround to revert to old behavior.

I have recently found were the problem came from and it made me improve my system setup in the process. I actually had a proxy issue. Accessing the world wide web from my network is done through a 8080 proxy server. For some reason, Firefox doesn't seem to check locally known hostnames before sending the request to the proxy and, from there, the DNS is checked. The complete list of hosts that shouldn't be contacted through the proxy is too long to be set directly in firefox's proxy ignore list, so I created a pac (javascript) file to assign this ignore list. Now that requests don't go to the proxy anymore, everything works fine.

So it wasn't a SAS or rbrowser issue per se. That said, it would have been nice to be able to set the target IP address to rbrowser rather than using a compulsory hostname.

View solution in original post


All Replies
SAS Employee
Posts: 102

remote browsing

You'll find information on Remote Browsing, as well as installation and setup information for the Remote Browser in the SAS 9.3 Companion doc for the pertinent operating system.  In your case, that would be the UNIX doc.  The specific section can be found at:

http://support.sas.com/documentation/cdl/en/hostunx/63053/HTML/default/viewer.htm#n0agb7ldq3e5zxn174...

- Mark

New Contributor
Posts: 4

remote browsing

Thank you for the (quick!) answer, but this rather scarse (no offense intended) documentation actually was what I was I referring to when mentioning "googling". Unfortunately, it says nothing about the configuration of the agent (or I've missed that part).

From what I understand, the helphost and helpport options only serve to tell SAS where to find the remote browser agent. This part of things seems to work, because the default configuration:

myself:~$ /usr/local/SAS/sas_9.3/SASFoundation/9.3/sas

leads to a SAS error window (saying how to download rbrowser) and no Internet browser firing up, like this:

sas-remote_default-mini.png

whilst the correct helphost option:

myself:~$ /usr/local/SAS/sas_9.3/SASFoundation/9.3/sas -helphost 127.0.0.1

causes Firefox to fire up. But, the URL sent to it is not correct, as you can see here:

sas_remote_browser_mini.png

So I'm still wondering how to configure the agent itself. I've not found documentation about possible command line arguments, only a "preferences" window that deals exclusively with the SAS client's properties and the executable path of the browser, but not with the content of the URL to be sent to the browser:

sas_remote_browser_preferences.png

I hope I have missed something because as I understand things so far, I'll have to set up a DNS-registered server dedicated to SAS display (both help and pictures) for all (not DNS-registered) clients.

Regards

Super User
Super User
Posts: 7,039

remote browsing

Two things that you could try.

1) Check what you are setting for your helphost.  Perhaps you need a more fully qualified name for your host?  Try referencing that host from an independent firefox session and see if you get the same DNS error message.

2) Check if your machine is blocking ranges of ports? Check both the listen port that you specify in the rbrowser setup (and in the helpport setting in SAS) and the port that you see in the error message. (56253 in your first screen shot above for example.)  I have no idea how to check this, but someone must.

SAS Employee
Posts: 25

remote browsing

The remote browser server is designed to be installed and run on a client (pc or linux), not on the server where SAS is executing.  By default the value of HELPHOST defaults to the host specified in the DISPLAY variable set for the terminal session, and uses port 3755.  With SSH X11 forwarding this can be problematic (http://support.sas.com/kb/34173).   You may also need to do some firewall modifications and use the environment variables  HTTPSERVERPORTMIN and HTTPSERVERPORTMAX to define a range of ports to use on the server.  With the Remote Browser Server correctly installed and executing, SAS will launch a client-side browser (either Internet Explorer or Firefox) on the PC to display the content.

It's also possible to revert to the SAS 9.1.3 behavior of launching a server-side browser. To do this for all SAS sessions on the server, include in SASFoundation/9.2/sasv9_local.cfg the lines:

   -helpbrowser SAS

   -xrm "SAS.webBrowser: /usr/bin/firefox"

   -xrm "SAS.helpBrowser: /usr/bin/firefox"

adjusting the path to launch Firefox as needed.

This isn't officially supported, but should work reasonably well.  There are some 'control' issues in relation to security changes in Firefox from Netscape that were not addressed - window closes, things like that.

Solution
‎11-02-2011 05:44 AM
New Contributor
Posts: 4

remote browsing

Thanks for your answers, they may come in very handy, particularly the workaround to revert to old behavior.

I have recently found were the problem came from and it made me improve my system setup in the process. I actually had a proxy issue. Accessing the world wide web from my network is done through a 8080 proxy server. For some reason, Firefox doesn't seem to check locally known hostnames before sending the request to the proxy and, from there, the DNS is checked. The complete list of hosts that shouldn't be contacted through the proxy is too long to be set directly in firefox's proxy ignore list, so I created a pac (javascript) file to assign this ignore list. Now that requests don't go to the proxy anymore, everything works fine.

So it wasn't a SAS or rbrowser issue per se. That said, it would have been nice to be able to set the target IP address to rbrowser rather than using a compulsory hostname.

Super User
Super User
Posts: 7,039

remote browsing

You can set an IP address.

options helphost='1.2.3.4';

New Contributor
Posts: 4

remote browsing

Yes, this option tells SAS where to find rbrowser and it works. But it wasn't the issue.

What I have not found is how to tell rbrowser where to find Firefox: it always tries to find it on `hostname`, which in my example was pg02 instead of 192.168.31.112, or even more conveniently 127.0.0.1 (no need to tweek the configuration for each computer with this one).

🔒 This topic is solved and locked.

Need further help from the community? Please ask a new question.

Discussion stats
  • 7 replies
  • 1118 views
  • 6 likes
  • 4 in conversation