Architecting, installing and maintaining your SAS environment

installation 9.4

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 10
Accepted Solution

installation 9.4

Hi all,

I try to install SAS 9.4 on Windows 7 x64 (SAS 9.4 TS1M2, Rev. 940_14w36) . The installation part runs successfully, but during configuration of different web applications (e.g. Web Infrastructure Platform, Backup and Recovery Tool,...) I receive the following error message:

2014-10-01 15:13:19,864 [main] ERROR com.sas.sdw.SDWExceptionHandler - java.io.IOException: Unable to delete directory D:\SAS\SAS94\config\Lev1\Web\Temp\explode_ear\sas.svcs.logon.war\WEB-INF\lib

Find the whole log-files in attachment.

Regards,

christoph

Attachment
Attachment

Accepted Solutions
Solution
‎10-07-2014 10:40 AM
SAS Employee
Posts: 102

Re: installation 9.4

Posted in reply to rico_ehrlich

"Caused by: java.io.IOException: Unable to delete directory D:\SAS\SAS94\config\Lev1\Web\Temp\explode_ear\sas.svcs.logon.war\WEB-INF\lib."

Is the true error, anything else can be ignored. When you tried this previously did it always error on the same folder? Can you confirm you can delete it manually? My thoughts would be the directory (or some file inside it) is locked by some other process (virus scanner running? command prompt open?) or that the permissions on the directory are somehow set to deny deletes. I'd wipe that Lev1\Web\Temp\explode_ear directory manually and retry.

View solution in original post


All Replies
Trusted Advisor
Posts: 3,212

Re: installation 9.4

Posted in reply to rico_ehrlich

there are a lot of messages as "property not set" in the top of the log files. Are you sure that are not the real errors to solve first?

---->-- ja karman --<-----
Occasional Contributor
Posts: 10

Re: installation 9.4

hi jaap,

do you have a hint how I can solve this "property not set" messages? because I didn't find useful help on my google search.

regards,

christoph

Trusted Advisor
Posts: 3,212

Re: installation 9.4

Posted in reply to rico_ehrlich

The SAS installation is having several steps.

The first one is deploying all loadables, easy to understand you can find all that in the SASHOME (C:\Program Files\SASHome\  in your case)

Within that you find a SASDeploymentManager and a Deployment validation. 

The next step is configuring all what is deployed as loadables. This is the log you have included.

There are a lot of default settings that can be used but also several you have to prepare first as some design question and setup at the OS-level.

That is about the ports services users and passwords going to be used.  Also what to do about logfiles (operations) should already being taken care of.

      

In your included logfiles I am seeing:

Property "iomsrv.metadatasrv.host" has not been set

Property "iomsrv.metadatasrv.port" has not been set

Property "oma.person.admin.login.userid" has not been set

Property "oma.person.admin.login.passwd" has not been set

Whether these are missing in your preparation for that configuration.

Perhaps I am too quick with that as at the half of your log there is a part is has those properties. Than you get that unexpected error xml: in the include logs with the advice to look at the log. (no helpful information in those logs). 

If you are convinced you have done all preparation steps as described. It is not something obvious having missed.
Did you contact TS?

---->-- ja karman --<-----
Occasional Contributor
Posts: 10

Re: installation 9.4

Hi Jaap,

I have done all points in the preparation part before the installation.

I have contacted the support hotline, but since two weeks, they haven't any idea what is the problem.

regards,

christoph

Trusted Advisor
Posts: 3,212

Re: installation 9.4

Posted in reply to rico_ehrlich

Hmm that is not nice. When you are under pressure you can try to eliminate possible causes. Trying to get hints eg SAS notes:

51244 - An error occurs after you follow instructions to create the /etc/opt/vmware directory when y...

44026 - The SAS® Deployment Wizard might start and then stop when you are installing SAS for Microso...
Did your try a complete fresh configuration?

---->-- ja karman --<-----
Occasional Contributor
Posts: 10

Re: installation 9.4

yes, I tried a complete new configuration. and before I tried this I have removed the configuration with the deployment manager completly.

thanks for the sas notes. I will have a look into.

Solution
‎10-07-2014 10:40 AM
SAS Employee
Posts: 102

Re: installation 9.4

Posted in reply to rico_ehrlich

"Caused by: java.io.IOException: Unable to delete directory D:\SAS\SAS94\config\Lev1\Web\Temp\explode_ear\sas.svcs.logon.war\WEB-INF\lib."

Is the true error, anything else can be ignored. When you tried this previously did it always error on the same folder? Can you confirm you can delete it manually? My thoughts would be the directory (or some file inside it) is locked by some other process (virus scanner running? command prompt open?) or that the permissions on the directory are somehow set to deny deletes. I'd wipe that Lev1\Web\Temp\explode_ear directory manually and retry.

Occasional Contributor
Posts: 10

Re: installation 9.4

yes, I deleted the directory manually and "retry", but then the same error come again.

Occasional Contributor
Posts: 10

Re: installation 9.4

The problem was the new version of virus scanner "Kaspersky". "Kaspersky" has scanned the config-folder, while the folder was excluded from scanning.

thanks for all tips and support from here.

regards,

christoph

SAS Employee
Posts: 102

Re: installation 9.4

Posted in reply to rico_ehrlich

If you can delete it manually, then it sounds like something is holding the directory open that shouldn't be. I'd use Sysinternals process explorer or some other utility to see who has open handles on that directory. Is there a virus scanner running, it could be holding a handle on that directory to scan it, but releasing it by the time you attempt to delete it manually.

🔒 This topic is solved and locked.

Need further help from the community? Please ask a new question.

Discussion stats
  • 10 replies
  • 1194 views
  • 0 likes
  • 3 in conversation