Architecting, installing and maintaining your SAS environment

Windows Security "Choose Certificate" popup every time Enterprise Guide starts

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 18
Accepted Solution

Windows Security "Choose Certificate" popup every time Enterprise Guide starts

[ Edited ]

Hi,

 

New (part-time) admin question.

 

Recently started receiving a pop up prompting for a certificate every time EG starts.  Checked the "Desktop Application Administration Guide" and do not see any mention of setting up certificates.  If I click cancel, everything works as expected.  It's really becoming a nuisance.  

 

Why is EG creating this prompt?

 

Environment is SAS 9.4M4 Grid on RHEL / EG 7.13

 

Thanks in advance!

 

EG.png


Accepted Solutions
Solution
3 weeks ago
SAS Employee
Posts: 61

Re: Windows Security "Choose Certificate" popup every time Enterprise Guide starts

[ Edited ]

I can only imagine its prompting for the TLS certificate to use for authententicating you with your organisations forward proxy server to access the Internet. At startup the SAS Enterprise Guide client will connect to SAS servers to check for updates. I'd enable the SAS Enterprise Guide log and when the prompt appears check where you are up to in the log. Once you OK the dialog perhaps the messages that follow in the log will give you an idea where its coming from.

View solution in original post


All Replies
Solution
3 weeks ago
SAS Employee
Posts: 61

Re: Windows Security "Choose Certificate" popup every time Enterprise Guide starts

[ Edited ]

I can only imagine its prompting for the TLS certificate to use for authententicating you with your organisations forward proxy server to access the Internet. At startup the SAS Enterprise Guide client will connect to SAS servers to check for updates. I'd enable the SAS Enterprise Guide log and when the prompt appears check where you are up to in the log. Once you OK the dialog perhaps the messages that follow in the log will give you an idea where its coming from.

Occasional Contributor
Posts: 18

Re: Windows Security "Choose Certificate" popup every time Enterprise Guide starts

Posted in reply to SimonDawson

Simon,

 

Turned on the logging and found that since there were two certs, EG was prompting me to choose one.  The bad news is that if I did choose one, the prompt just reappears.  The only way to clear it is to choose 'cancel'. 

 

From there, I went into the Windows Certificate Manager and deleted the older cert from my Personal folder and when I started EG, it came up without the prompt  Problem solved.

 

Many thanks for the tip!

 

Ken

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 2 replies
  • 152 views
  • 3 likes
  • 2 in conversation