Architecting, installing and maintaining your SAS environment

Windows Explorer does not recognize SAS programs since I installed SAS 9.3

Reply
Contributor
Posts: 29

Windows Explorer does not recognize SAS programs since I installed SAS 9.3

Ever since I installed SAS 9.3 I'm experiencing little technical issues; more of an annoyance than anything else. I am wondering if something went wrong during installation?

Mostly, explorer doesn't seem to recognize SAS programs. The icon next to a program is generic. When I right-click on a program in an explorer window, it doesn't give me the option to open in SAS (if I try open-with, it batch-submits rather than opening a SAS session). I can't right-click within an empty folder and insert a new SAS program, either. None of these are preventing me from getting any work done, but they do introduce some inefficiencies.

I am considering re-installing SAS 9.3, but I wanted to see if anyone has other suggestions or explanations first. I have Windows XP.

Thank you!

SAS Employee dbm
SAS Employee
Posts: 2

Windows Explorer does not recognize SAS programs since I installed SAS 9.3

Maybe it's a bit too late, but have you tried going to start menu --> SAS --> Utilities --> Manage SAS File Types and fix it from there?

BR,

Dušan

Occasional Contributor
Posts: 17

Windows Explorer does not recognize SAS programs since I installed SAS 9.3

Have you checked the File Type options for windows?  If you have a window open in explorer, you should be able to go to:

Tools > Folder Options > File Types (tab)

Did the associated file types get messed up or changed?

You can set the extension to the SAS program that opens it, this should fix the issue, if I understand the problem correctly. :-)

Good luck!

Contributor
Posts: 66

Windows Explorer does not recognize SAS programs since I installed SAS 9.3

You must have disallowed registration of SAS-specific file extensions with SAS software at the end of your installation. You can do it now from Windows Explorer, but specific menus may differ from one version of Windows to another. I have Vista and the instructions above by Robbie do not work - no such tab any more.

Try right-clicking (you may have to do simultaneous Shift and right click) on the program file (filename.sas) and select Open With... There might be some applications to choose from like Notepad, Internet Explorer, Word, etc. Select Choose Default Program..., the last item on the menu - a new window opens. At the bottom there should be a Browse button. Click on it and navigate to SAS 9.3 SASHOME directory and select sas.exe file. Check the box to always open with this program and click Save.

The SASHOME should be something like this: C:\Program Files\SAS\SASFoundation\9.3  - you must find sas.exe file.

You can do the same with SAS datasets extensions, catalogs, macros, etc. I prefer .LOG files to remain associated with Notepad, because many other programs create log files, including Windows OS.  If you have SAS Universal Viewer, you can associate the data files with it.

Ask a Question
Discussion stats
  • 3 replies
  • 996 views
  • 0 likes
  • 4 in conversation