Architecting, installing and maintaining your SAS environment

Web application using SAS

Reply
Occasional Contributor
Posts: 5

Web application using SAS

[ Edited ]

Hi,

We have a customize portal build in Websphere and was called using link portlate from SAS IDP in SAS9.3

Since we have moved to SAS9.4 we want to migrate the portal to SAS Tomcat Webapplication, but we are facing issues.

We have made entries in sas.conf file as show below, and also created folder in webapps but still we get 404 error.

Please suggest what we need to follow to get it fixed.

 

ProxyPass /rute balancer://dc5coj.ca_Cluster1/rute
ProxyPassReverse /rute balancer://dc5coj.ca_Cluster1/rute


<Proxy balancer://dc5coj.ca_Cluster1>
BalancerMember http://dc5coj.ca:8088 route=cf0c1e7d7f2ce2660656f9f7006be89e_SASServer1_1
ProxySet scolonpathdelim=on stickysession=48eaeab5502188f28e0b663f0039982a_Cluster1
</Proxy>

SAS Employee
Posts: 102

Re: Web application using SAS

Posted in reply to Nishant2000

Did you reload apache after the change?

 If you visit  http://dc5coj.ca:8088/rute directly, does the page display as expected? If not, the problem is on the web app server side, if it does, the error is on the web server side.

Occasional Contributor
Posts: 5

Re: Web application using SAS

Thanks, I was able to get the solution.

The issue was with the conversion of EAR file to WAR file. We were not using proper version.

After conversion we made proper entry in sas.conf file, invoked this file from http.conf. After complete restart it worked Smiley Happy 

SAS Super FREQ
Posts: 299

Re: Web application using SAS

Posted in reply to Nishant2000

Hi,

 

Take a look at

http://support.sas.com/resources/papers/proceedings14/SAS357-2014.pdf

for some pointers.

 

Also, when exactly do you get an error message? What are the issues you are facing?

 

I would probably open a track with Tech Support to get some input/suggestions.

 

Thanks

Anja

Occasional Contributor
Posts: 5

Re: Web application using SAS

Thanks, I was able to get the solution.
The issue was with the conversion of EAR file to WAR file. We were not using proper version.
After conversion we made proper entry in sas.conf file, invoked this file from http.conf. After complete restart it worked Smiley Happy
Ask a Question
Discussion stats
  • 4 replies
  • 220 views
  • 0 likes
  • 3 in conversation