Architecting, installing and maintaining your SAS environment

WFSRestore Help Needed

Reply
New Contributor
Posts: 3

WFSRestore Help Needed

Hi Everyone,

I'm not certain this is the most appropriate location for this discussion as this isn't a deployment question, but I need some Admin help please.

We are using AIX 5.3 with SAS Marketing Automation 4.4, SAS 9.1.3 and a Xythos WebDAV database running on Oracle.  The entire database was accidentally dropped and I am the lucky person who gets to restore it.

I have nightly backups created by the WFSDump utility as well as OMA backups.  Since our DB was the only thing affected, I started to run the WFSRestore script with the followig command:

sasma@rcirs080:/opt/sas9/Components/xythos/custom/bin > WFSRestore /edwpl/ma/_Backups/XythosWFSDump/2011.11.25_00.00.55

Most of the output that I see on the console looks like this...

[2011-11-27T04:13:39Z]  Trace JdbcConnPool      PeriodicDaemonThread:48 Running JDBCConnectionPoolThread

[2011-11-27T04:13:39Z]  Trace JdbcConnPool      PeriodicDaemonThread:52 Done running JDBCConnectionPoolThread

[2011-11-27T04:13:39Z]  Trace Misc      PeriodicDaemonThread:48 Running XythosXSSLoggerThread

[2011-11-27T04:13:39Z]  Trace Misc      PeriodicDaemonThread:52 Done running XythosXSSLoggerThread

[2011-11-27T04:13:44Z]  Trace Misc      PeriodicDaemonThread:48 Running XythosXSSLoggerThread

[2011-11-27T04:13:44Z]  Trace Misc      PeriodicDaemonThread:52 Done running XythosXSSLoggerThread

...repeated over and over and over again.  This being my first attempt at restoring my Xythos DB, I opened a case with SAS to get some guidance.  I was told that I am doing this correctly, however it's been 30 hrs and this restore is still happening!  The backup folder is approx 1.5GB in size and my WFSDump.xml is approx 13MB.

I need to know how much longer this is going to take?  I asked SAS if there was anything I could do to see how much of the restore had completed and didn't get any useful information.  Has anyone else had to do this before and do you have any details that you could share?

Thanks in advance!

SAS Employee
Posts: 13

Re: WFSRestore Help Needed

Tech Support was able to help resolve this problem.

WFSRestore expects a configured (albeit new initialized) Xythos system, and there are some required user dialogs.  

Some cleanup was needed because the process skipped the restoration of  MA files that already existed in the repository.  We cleaned up the repository, ran the restore again and all appears to be working.   

Ask a Question
Discussion stats
  • 1 reply
  • 226 views
  • 0 likes
  • 2 in conversation