Architecting, installing and maintaining your SAS environment

Unable to update SAS license for Mid-Tier

Reply
Contributor
Posts: 26

Unable to update SAS license for Mid-Tier

[ Edited ]

Hi,

 

There was SAS License Renewal update with our SAS 9.4 Architecture recently. We were successful in updating the same with SAS Metadata and SAS Compute , even with SAS SPDS and SAS LSF but couldn’t do the same with SAS Mid-tier.

 

Our SAS Architecture includes SAS Metadata and SAS Compute in AIX environment and SAS Mid tier in Linux environment. Since Mid tier is altogether different Operating system and File system we expect to apply the license separately. (Correct us if the assumption is incorrect) . With that said , we are not able to find ‘Renew SAS Software ’ option with the SAS Deployment Manager. 

 

Attaching SAS Deployment Manager screen shots herewith. Let me know for more details.


SDM_2.JPGSDM_1.JPG
Frequent Contributor
Posts: 96

Re: Unable to update SAS license for Mid-Tier

Hi @sram4790;

 

For Midtier you will not get the option of Renew SAS Software, because midtier doesn't need the license renewal. so that's why you can not see Renew SAS Software.

Contributor
Posts: 26

Re: Unable to update SAS license for Mid-Tier

Posted in reply to Kalind_Patel

Hi Kalind,

 

I am not really sure about this , because we have a Test environment which gives me an option 'Renew SAS Software'.

Frequent Contributor
Posts: 96

Re: Unable to update SAS license for Mid-Tier

Hi @sram4790;

 

Are you sure your test environment has the same architecture ? or it is single machine arch only?

 

Because in middle tear you don't need to update the license,

you can also ask to SAS Tech Support for more clarifications. they can help you on this.

 

Super User
Posts: 3,256

Re: Unable to update SAS license for Mid-Tier

[ Edited ]

Have you done all the steps in these instructions including the step for SID File Update in Metadata this is required for mid-tier applications listed like SAS VA.

 

http://support.sas.com/documentation/installcenter/en/ikunixplannedri/66610/PDF/default/setinit_plan...

 

Contributor
Posts: 26

Re: Unable to update SAS license for Mid-Tier

The only way to update SAS license for Mid tier in a grided environment is by using the option "Update SID in Metadata" in SAS Deployment Manager.

 

We updated the same and was successful . Thank you all for the support!!

Ask a Question
Discussion stats
  • 5 replies
  • 329 views
  • 4 likes
  • 3 in conversation