Architecting, installing and maintaining your SAS environment

Unable to Start SASServer2_1 during SAS upgrade

Reply
Contributor
Posts: 65

Unable to Start SASServer2_1 during SAS upgrade

We are getting the error to start the SASServer2_1 server during upgrade from SAS 9.4 M3 to M4.

 

The following problem was encountered while configuring SAS Web Application Server Configuration:

Timeout for Application Server startup has reached before port opened.

Configuration script: /opt/sas/software/SASDeploymentManager/9.4/products/cfgwizard__94480__prt__xx__sp0__1/Utilities/AppServer/Source/Ant/appserver_config.xml For more information, see the log file located at

 

Here is SAS Web app server status: 

SAS Web App Server SASServer1_1 is UP
SAS Web App Server SASServer12_1 is UP
SAS Web App Server SASServer2_1 is NOT up

 

We have restarted the ./httpdctl using root user because the server is configured to listen on ports below 1024 on Linux.

 

Here is config log : -


[appserverTarget] 2017-07-10 15:23:19,591 [main] INFO com.sas.appserver.utils.PortUtils - isPortAvailable() <<<
[appserverTarget] 2017-07-10 15:23:19,623 [main] INFO com.sas.appserver.vfabrictcsvr.Server - Waiting for port (8180) to open on address (server.name).
[appserverTarget] 2017-07-10 15:23:29,624 [main] INFO com.sas.appserver.utils.PortUtils - isPortAvailable(server.name,8180) >>>
[appserverTarget] 2017-07-10 15:23:29,624 [main] INFO com.sas.appserver.utils.PortUtils - Connection refused
[appserverTarget] 2017-07-10 15:23:29,625 [main] INFO com.sas.appserver.utils.PortUtils - isAvailable=true
[appserverTarget] 2017-07-10 15:23:29,625 [main] INFO com.sas.appserver.utils.PortUtils - isPortAvailable() <<<
[appserverTarget] 2017-07-10 15:23:29,656 [main] INFO com.sas.appserver.vfabrictcsvr.Server - Waiting for port (8180) to open on address (server.name).
[appserverTarget] 2017-07-10 15:23:39,657 [main] INFO com.sas.appserver.utils.PortUtils - isPortAvailable(server.name,8180) >>>
[appserverTarget] 2017-07-10 15:23:39,657 [main] INFO com.sas.appserver.utils.PortUtils - Connection refused
[appserverTarget] 2017-07-10 15:23:39,658 [main] INFO com.sas.appserver.utils.PortUtils - isAvailable=true
[appserverTarget] 2017-07-10 15:23:39,658 [main] INFO com.sas.appserver.utils.PortUtils - isPortAvailable() <<<
[appserverTarget] 2017-07-10 15:23:39,689 [main] INFO com.sas.appserver.vfabrictcsvr.Server - Waiting for port (8180) to open on address (server.name).

 

 

Please advise?

SAS Super FREQ
Posts: 299

Re: Unable to Start SASServer2_1 during SAS upgrade

Posted in reply to sewa_bal_gmail_com

Hi.

 

Take a look at the following SAS Note: http://support.sas.com/kb/57/029.html

 

I'd like to make a suggestion: if you have not opened a track with Tech Sup yet, maybe it

would be a good next step to make sure the upgrade to M4 runs smoothly.

As I recall, you ran into a web config problem in an earlier step of the upgrade. Maybe Tech Sup

could help to evaluate and make sure the environment is upgraded successfully, to make sure

there won't be any problems later on once the upgrade is done.

 

Best

Anja

Contributor
Posts: 73

Re: Unable to Start SASServer2_1 during SAS upgrade

Posted in reply to sewa_bal_gmail_com
Hi @sewa_bal_gmail_com

I would suggest sharing the Server2_1 catalina.out log details for the exact error to understand what could be causing this issue.

Thanks,
AV
Contributor
Posts: 65

Re: Unable to Start SASServer2_1 during SAS upgrade

Hi Anand_V,

 

Please see the log of server2_1

 

21:36:07,054 | WARN | [JmxSocketListener] | Detected LDAP configuration '/opt/sas/config/Lev1/Web/WebAppServer/SASServer2_1/conf/jaas.config', but there is no ldap configuration entry specified.
21:36:07,083 | INFO | [Catalina] | Initialization processed in 549 ms
21:36:07,114 | FATAL | [Catalina] | The required Server component failed to start so Tomcat is unable to start.
org.apache.catalina.LifecycleException: Failed to start component [StandardServer[-1]]
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:154)
at org.apache.catalina.startup.Catalina.start(Catalina.java:689)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:321)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:455)
Caused by: java.lang.NoSuchMethodError: org.apache.activemq.pool.AmqJNDIPooledConnectionFactory.getConnectionFactory()Ljavax/jms/ConnectionFactory;
at org.apache.activemq.pool.AmqJNDIPooledConnectionFactory.buildFromProperties(AmqJNDIPooledConnectionFactory.java:87)
at org.apache.activemq.pool.AmqJNDIPooledConnectionFactory.setProperties(AmqJNDIPooledConnectionFactory.java:55)
at org.apache.activemq.jndi.JNDIReferenceFactory.getObjectInstance(JNDIReferenceFactory.java:73)
at org.apache.naming.factory.ResourceFactory.getObjectInstance(ResourceFactory.java:141)
at javax.naming.spi.NamingManager.getObjectInstance(NamingManager.java:321)
at org.apache.naming.NamingContext.lookup(NamingContext.java:842)
at org.apache.naming.NamingContext.lookup(NamingContext.java:153)
at org.apache.naming.NamingContextBindingsEnumeration.nextElementInternal(NamingContextBindingsEnumeration.java:117)
at org.apache.naming.NamingContextBindingsEnumeration.next(NamingContextBindingsEnumeration.java:71)
at org.apache.naming.NamingContextBindingsEnumeration.next(NamingContextBindingsEnumeration.java:34)
at org.apache.catalina.mbeans.GlobalResourcesLifecycleListener.createMBeans(GlobalResourcesLifecycleListener.java:138)
at org.apache.catalina.mbeans.GlobalResourcesLifecycleListener.createMBeans(GlobalResourcesLifecycleListener.java:145)
at org.apache.catalina.mbeans.GlobalResourcesLifecycleListener.createMBeans(GlobalResourcesLifecycleListener.java:145)
at org.apache.catalina.mbeans.GlobalResourcesLifecycleListener.createMBeans(GlobalResourcesLifecycleListener.java:110)
at org.apache.catalina.mbeans.GlobalResourcesLifecycleListener.lifecycleEvent(GlobalResourcesLifecycleListener.java:82)
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117)
at org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:90)
at org.apache.catalina.util.LifecycleBase.setStateInternal(LifecycleBase.java:402)
at org.apache.catalina.util.LifecycleBase.setState(LifecycleBase.java:347)
at org.apache.catalina.core.StandardServer.startInternal(StandardServer.java:732)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
... 7 more
21:36:07,117 | WARN | [LifecycleBase] | Calling stop() on failed component [StandardServer[-1]] to trigger clean-up did not complete.
org.apache.catalina.LifecycleException: Failed to stop component [StandardServer[-1]]
at org.apache.catalina.util.LifecycleBase.stop(LifecycleBase.java:236)
at org.apache.catalina.util.LifecycleBase.destroy(LifecycleBase.java:272)
at org.apache.catalina.startup.Catalina.start(Catalina.java:693)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:321)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:455)
Caused by: org.apache.catalina.LifecycleException: An invalid Lifecycle transition was attempted ([before_stop]) for component [StandardService[Catalina]] in state [INITIALIZED]
at org.apache.catalina.util.LifecycleBase.invalidTransition(LifecycleBase.java:409)
at org.apache.catalina.util.LifecycleBase.stop(LifecycleBase.java:219)
at org.apache.catalina.core.StandardServer.stopInternal(StandardServer.java:760)
at org.apache.catalina.util.LifecycleBase.stop(LifecycleBase.java:232)
... 8 more

Contributor
Posts: 65

Re: Unable to Start SASServer2_1 during SAS upgrade

Posted in reply to sewa_bal_gmail_com

Hi All,

 

 

Please advise?

 

SASServer2_1 is not up during configuration. 

 

SAS Web App Server SASServer1_1 is UP
SAS Web App Server SASServer12_1 is UP
SAS Web App Server SASServer2_1 is NOT up

 

config logs

[appserverTarget] 2017-07-11 15:08:44,844 [main] INFO com.sas.appserver.utils.AntProcessInvoker - Environment Variables:
[appserverTarget] 2017-07-11 15:08:44,844 [main] INFO com.sas.appserver.utils.AntProcessInvoker - Working Directory: /opt/sas/config/Lev1/Web/WebAppServer/SASServer2_1/bin
[appserverTarget] 2017-07-11 15:08:44,844 [main] INFO com.sas.appserver.utils.AntProcessInvoker - Executable: /opt/sas/config/Lev1/Web/WebAppServer/SASServer2_1/bin/tcruntime-ctl.sh
[appserverTarget] 2017-07-11 15:08:44,844 [main] INFO com.sas.appserver.utils.AntProcessInvoker - Arguments:
[appserverTarget] 2017-07-11 15:08:44,844 [main] INFO com.sas.appserver.utils.AntProcessInvoker - start
[appserverTarget] 2017-07-11 15:08:44,845 [main] INFO com.sas.appserver.utils.AntProcessInvoker - spawning process
[appserverTarget] 2017-07-11 15:08:44,847 [main] INFO com.sas.appserver.vfabrictcsvr.Server - server.name SASServer2 using http on port 8180
[appserverTarget] 2017-07-11 15:08:54,848 [main] INFO com.sas.appserver.utils.PortUtils - isPortAvailable(server.name,8180) >>>
[appserverTarget] 2017-07-11 15:08:54,849 [main] INFO com.sas.appserver.utils.PortUtils - Connection refused
[appserverTarget] 2017-07-11 15:08:54,849 [main] INFO com.sas.appserver.utils.PortUtils - isAvailable=true
[appserverTarget] 2017-07-11 15:08:54,849 [main] INFO com.sas.appserver.utils.PortUtils - isPortAvailable() <<<

 

 

 

Ask a Question
Discussion stats
  • 4 replies
  • 277 views
  • 0 likes
  • 3 in conversation