Architecting, installing and maintaining your SAS environment

The SAS VA Web App Server SASSERVER1_1 suddenly stops running

Accepted Solution Solved
Reply
New Contributor
Posts: 3
Accepted Solution

The SAS VA Web App Server SASSERVER1_1 suddenly stops running

Our SAS VA (7.3) Web App Server will suddenly stop while the rest of the SAS services are operating normally. This has happened twice. We are in a SAS VA Distributed environment  on Unix.  Has anyone else had this happen? Also how do we prevent this from happening or can it be prevented?

 

Note: The service can be started again successfully.

Thank you, Patti


Accepted Solutions
Solution
‎03-31-2017 05:54 PM
New Contributor
Posts: 3

Re: The SAS VA Web App Server SASSERVER1_1 suddenly stops running

Thank you. I will have to wait and see if this happens again and not restart the SAS WebApp server until I review all the logs.

Thanks for your advice.

Patti

View solution in original post


All Replies
Super User
Posts: 3,250

Re: The SAS VA Web App Server SASSERVER1_1 suddenly stops running

Have you checked the SASSERVER1_1 server log for evidence of any problems?

SAS Super FREQ
Posts: 299

Re: The SAS VA Web App Server SASSERVER1_1 suddenly stops running

Hi,

 

take a look at the gemfire log:

sasconfigdir...\Lev1\Web\gemfire\instances\....

and, as it was suggested, the sasserver1_1 log at sasconfigdir\...\Lev1\Web\WebAppServer\SASServer1_1\logs

 

Any errors?

 

Thanks

Anja

New Contributor
Posts: 3

Re: The SAS VA Web App Server SASSERVER1_1 suddenly stops running

Thank you. I restarted the server too soon and it erased the entries in the gemfire.log file.

But, I did discover that the server failed (stopped) because free memory space was chewed up to a point to where the Web App Server could no longer function. The problem is the free memory space started to decline at 1:00 am when no one is using the VA environment and no processes /scheduled jobs have been implemented in that Linux environment.  Now I just dont know what would cause that.

Super User
Posts: 3,250

Re: The SAS VA Web App Server SASSERVER1_1 suddenly stops running

Perhaps keep monitoring memory usage for a few days to see if there is a pattern emerging or if the problem was a one-off event. One-off problems can be tricky, and if no evidence can be found for the cause then often the approach could be just to monitor more closely in case the problem reappears.

 

If you haven't done so already then checking the server's OS event logs around 1:00am could be worthwhile to see if anything related may have happened.

Solution
‎03-31-2017 05:54 PM
New Contributor
Posts: 3

Re: The SAS VA Web App Server SASSERVER1_1 suddenly stops running

Thank you. I will have to wait and see if this happens again and not restart the SAS WebApp server until I review all the logs.

Thanks for your advice.

Patti

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 5 replies
  • 282 views
  • 2 likes
  • 3 in conversation