Architecting, installing and maintaining your SAS environment

SAS is not able to use most recent kerb token on CIFS share on Linux.

Reply
Occasional Contributor
Posts: 10

SAS is not able to use most recent kerb token on CIFS share on Linux.

Please see below SAS log from Eguide  project. I  can't access below directory . I can access the below dir using Eguide when do the  "LS" in the putty...  This keeps happening and Users are frustated .. Please help us . if you have already faced below issue..

 

 

NOTE: The infile FOO is:
Pipe command="klist; ls -ld /mnt/sasshared/test_dir; ls -la /mnt/sasshared/test_dir"

Ticket cache: FILE:/tmp/krb5cc_202150_lQ7Sgq
Default principal: xxxx@CORP.xxxxx.COM

Valid starting Expires Service principal
05/23/16 09:44:44 05/23/16 21:44:47 krbtgt/CORP.xxxx.COM@CORP.xxxx.COM
renew until 05/31/16 09:44:44
ls: cannot access /mnt/sasshared/test_dir: Permission denied

 

ls: cannot access /mnt/sasshared/test_dir: Permission denied
NOTE: 8 records were read from the infile FOO.
The minimum record length was 0.
The maximum record length was 80.
NOTE: DATA statement used (Total process time):
real time 0.14 seconds
cpu time 0.01 seconds

 

in var/log/messages , I  get below information.

ay 23 09:44:56 axxxxxx001ap kernel: CIFS VFS: Send error in SessSetup = -128
May 23 09:49:47 axxxxxx001ap kernel: CIFS VFS: Send error in SessSetup = -128
May 23 09:50:16 axxxxxx001ap kernel: CIFS VFS: Send error in SessSetup = -128
May 23 09:50:20 axxxxxx001ap kernel: CIFS VFS: Send error in SessSetup = -128
May 23 09:50:22 axxxxxx001ap kernel: CIFS VFS: Send error in SessSetup = -128
May 23 09:50:28 axxxxxx001ap kernel: CIFS VFS: Send error in SessSetup = -128
May 23 09:50:37 axxxxxx001ap kernel: CIFS VFS: Send error in SessSetup = -128

Community Manager
Posts: 2,768

Re: SAS is not able to use most recent kerb token on CIFS share on Linux.

I see you had another thread about moving your SAS environment to a new box.  Is this related?  Are things not working properly on the new environment?

 

Be sure that you followed the checklist in configuring IWA.  Check especially that the sasauth.conf file has the proper settings.

 

Review also the information in this excellent paper by Stuart Rogers of SAS, Kerberos Delegation with SAS 9.4.  Especially the customizations you might need to make for the ../Lev1/level_env_usermods.sh file.

 

Chris

 

 

Ask a Question
Discussion stats
  • 1 reply
  • 236 views
  • 0 likes
  • 2 in conversation