Architecting, installing and maintaining your SAS environment

SAS Visual Analytics, switch from IPv6 to IPv4

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 9
Accepted Solution

SAS Visual Analytics, switch from IPv6 to IPv4

Hi All,

we've received and (hopefully) succesfully installed VA on single machine linux server. But probably while installing i missclicked ipv4 option. Which lead to following situation:

 

Welcome page (you have succesfully set the web server blahblah) works.

 

But other pages (applications) like SASStudio, SASVisualAnalyticsHub etc are unreachable. 

Using linux tools it seems that SAS is listening only on IPv6 address.

 

Is there any posibility to switch to IPv4 without reinstalling whole solution?

 

I tried to switch all jvm options with ipv4 to true (preferipv4stack) but it had no success.

 

Thank you!

Have a nice Day

Michal


Accepted Solutions
Solution
‎03-20-2017 10:01 AM
Trusted Advisor
Posts: 1,141

Re: SAS Visual Analytics, switch from IPv6 to IPv4

Hello @miki7,

 

do you have a distributed (multiple nodes) or a non-distributed version of Visual Analytics?

 

Here is the thing, a couple of considerations:

 

- if you have a non-distributed version of VA, I would just re-install and migrate the content. Simplier, cleaner and quicker.

- Now, if your configuration was done using fully quallified hostnames (fqdn), in general you should be able to switch to ipv4, although you might need to grep (search) your configuration files to change the multicast address, and maybe some ips. 

- If you change tyo ipv4, I strongly recommend you to keep only one ip per node, at least for the initial change, otherwise you would introduce an unnecesary risk on the change.

View solution in original post


All Replies
Solution
‎03-20-2017 10:01 AM
Trusted Advisor
Posts: 1,141

Re: SAS Visual Analytics, switch from IPv6 to IPv4

Hello @miki7,

 

do you have a distributed (multiple nodes) or a non-distributed version of Visual Analytics?

 

Here is the thing, a couple of considerations:

 

- if you have a non-distributed version of VA, I would just re-install and migrate the content. Simplier, cleaner and quicker.

- Now, if your configuration was done using fully quallified hostnames (fqdn), in general you should be able to switch to ipv4, although you might need to grep (search) your configuration files to change the multicast address, and maybe some ips. 

- If you change tyo ipv4, I strongly recommend you to keep only one ip per node, at least for the initial change, otherwise you would introduce an unnecesary risk on the change.

Occasional Contributor
Posts: 9

Re: SAS Visual Analytics, switch from IPv6 to IPv4

Hi @JuanS_OCS,

we have non-distrubuted version.

To reinstall, is it cool to just stop all servers, kill ALL sas processes, delete install folder and start over? 

 

Thank you very much.

 

Michal

Trusted Advisor
Posts: 1,141

Re: SAS Visual Analytics, switch from IPv6 to IPv4

[ Edited ]

Hi there @miki7,

 

it is safe if you work with a Linux server. if you have SAS VA on a Windows Server, better to follow the procedures to remove the configuration.

 

BTW: to don't need to remove the binaries (SASHome), only the configuration (Config/Lev1).

Occasional Contributor
Posts: 9

Re: SAS Visual Analytics, switch from IPv6 to IPv4

[ Edited ]

Dear @JuanS_OCS,

im usin linux so ill try to apply your advice.

 

before ill start reinstalling whole solution. Do you have any idea what sort of problem could be that welcome page works and applications dont? All services (using sas.servers status) are up. If i try to connect other appliactions via browser it just keeps connecting and then fails on time out. if i try to send get using curl there is no response. 

 

BUT 

 

when im starting server, the pages says classic "http 500" which is normal on start. But when sasServer_1 service is started, i just cant reach them any of these apps.

 

THANKS!!!

 

 

Trusted Advisor
Posts: 1,141

Re: SAS Visual Analytics, switch from IPv6 to IPv4

Hello @miki7,

 

the only way to know for sure, is to check your logs on the web server, the web application servers and on the web applications.

If you need an answer, and since you don;t have a very specific question/error, you can always open a track with SAS Technical Support and send them all the logs.

 

Before re-installing: are you able to validate your SAS Content Server, with the SAS Management Console? If it gives an error, please post it here.

 

My expectations/guesses: or the configuration was different when the SAS software was initially deployed, or something changed on your infrastructure (firewalls, etc), or something changed your configuration of SAS. SSL/certificates? Maybe your certificates are expired?

 

 

Occasional Contributor
Posts: 9

Re: SAS Visual Analytics, switch from IPv6 to IPv4

Thank you very much for your help.

Reinstall was really the quickiest way and now everything works like a charm Smiley Happy

Trusted Advisor
Posts: 1,141

Re: SAS Visual Analytics, switch from IPv6 to IPv4

Hello @miki7,

 

I am really glad that it helped you Smiley Happy

 

I just realized this question is more technical than functional, and I would like other users to be able to find their solution to similar questions. Therefore, I hope you won't mind I move this thread to the Administrators Community, to get better audience.

 

Perhaps you could mark the correct message as Solution to your question? Thank you in advance! That would help

 

Juan

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 7 replies
  • 248 views
  • 4 likes
  • 2 in conversation